summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-28 22:30:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-28 22:50:29 +0100
commit916649ceeb328dc7b332ee5cbc70cd7c84ee37cb (patch)
tree33c738b0782bc2760f9c01024fc33bc6ed9cc493 /dev-python/pytest
parentdev-python/pytest: Use epytest to run tests (diff)
downloadgentoo-916649ceeb328dc7b332ee5cbc70cd7c84ee37cb.tar.gz
gentoo-916649ceeb328dc7b332ee5cbc70cd7c84ee37cb.tar.bz2
gentoo-916649ceeb328dc7b332ee5cbc70cd7c84ee37cb.zip
dev-python/pytest: Deselect tests fragile to pytest plugins
Deselect the tests that explicitly patch PYTEST_DISABLE_PLUGIN_AUTOLOAD out and therefore fail when some pytest plugins are installed. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-6.2.5-r2.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/pytest/pytest-6.2.5-r2.ebuild b/dev-python/pytest/pytest-6.2.5-r2.ebuild
index c55df4717bb1..6679e63a6906 100644
--- a/dev-python/pytest/pytest-6.2.5-r2.ebuild
+++ b/dev-python/pytest/pytest-6.2.5-r2.ebuild
@@ -58,6 +58,19 @@ python_test() {
local EPYTEST_DESELECT=(
# broken by epytest args
testing/test_warnings.py::test_works_with_filterwarnings
+
+ # tend to be broken by random pytest plugins
+ # (these tests patch PYTEST_DISABLE_PLUGIN_AUTOLOAD out)
+ testing/test_helpconfig.py::test_version_less_verbose
+ testing/test_helpconfig.py::test_version_verbose
+ testing/test_junitxml.py::test_random_report_log_xdist
+ testing/test_junitxml.py::test_runs_twice_xdist
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal_count
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_verbose
+ testing/test_terminal.py::TestProgressWithTeardown::test_xdist_normal
+ testing/test_terminal.py::TestTerminalFunctional::test_header_trailer_info
+ testing/test_terminal.py::TestTerminalFunctional::test_no_header_trailer_info
)
epytest -p xdist -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"