summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-05 15:56:45 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-11-05 16:20:54 -0400
commit4a7ed36dd76eab84ff7f6490b4e8d6daa1444e80 (patch)
treeee39cdef009ed6c33662e73025ebd3c974c4036c /dev-python/pytest-bdd
parentdev-util/pkgcheck: Stabilize 0.10.17 ppc, #879905 (diff)
downloadgentoo-4a7ed36dd76eab84ff7f6490b4e8d6daa1444e80.tar.gz
gentoo-4a7ed36dd76eab84ff7f6490b4e8d6daa1444e80.tar.bz2
gentoo-4a7ed36dd76eab84ff7f6490b4e8d6daa1444e80.zip
dev-python/pytest-bdd: add 6.1.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 432f90cfff35..aeee3d8121b0 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1 +1,2 @@
DIST pytest-bdd-6.0.1.gh.tar.gz 60932 BLAKE2B 67e0dbc251ce94da40033641f37e6c9ad70ca947f71db1a78907a6890d96d8d3112d57a2a63dda526c8f846010d39a575cb5d93a102f4653705d4229ee14ab07 SHA512 30bc697ae177e3f311af0c781e99bde5b491dfef28109359c0d80f33feb8b0b170ffe15c288fe73a624144a1d1c3223b220d591b4acc30d1ad53600482bef87d
+DIST pytest-bdd-6.1.0.gh.tar.gz 79270 BLAKE2B 145d1adc6dae8098b30bfd68ce78dcf3c0b6626a32f8da05805f78f176111dd367a62e76eb61d520391c88bf9eda234f63d983bcfa36f00d39d85a026c78f883 SHA512 957b39a9c7c48b8d5e42d301de875579d062744766c55ffa32aed78a5a8a5c9fd9bb3ba281183841bc1da19604659c94ecaa4487dfc7a6dd69b507f5fc9f2dc7
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild
new file mode 100644
index 000000000000..a8fc183a60ad
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}