summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-02-01 02:35:33 +0100
committerLouis Sautier <sautier.louis@gmail.com>2016-02-01 02:42:22 +0100
commitc1f9eae2aaf0f57da949d20b601985c55a053870 (patch)
treeee1a8b3c85d0b663f3a81a6344f945f55d35c403 /dev-python/pysrt/pysrt-9999.ebuild
parentdev-lang/falcon: Drop old (diff)
downloadgentoo-c1f9eae2aaf0f57da949d20b601985c55a053870.tar.gz
gentoo-c1f9eae2aaf0f57da949d20b601985c55a053870.tar.bz2
gentoo-c1f9eae2aaf0f57da949d20b601985c55a053870.zip
dev-python/pysrt: support Python 3.5, fix tests, take package
Pull releases from github instead of pypi Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/pysrt/pysrt-9999.ebuild')
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index 374a8c7f8ddc..52db6b6d427d 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1 git-r3
@@ -16,12 +16,13 @@ SLOT="0"
KEYWORDS=""
IUSE="test"
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[coverage(+),${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
"
python_test() {