summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-04 04:33:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-04 04:33:33 +0200
commit69539d6e9ba1d587fd96bf42f1ffa102437acbf5 (patch)
tree3bb637309721297921eb842b3c6e5e5de4331c4a /dev-python/pyproject-fmt
parentdev-python/griffe: Bump to 0.31.0 (diff)
downloadgentoo-69539d6e9ba1d587fd96bf42f1ffa102437acbf5.tar.gz
gentoo-69539d6e9ba1d587fd96bf42f1ffa102437acbf5.tar.bz2
gentoo-69539d6e9ba1d587fd96bf42f1ffa102437acbf5.zip
dev-python/pyproject-fmt: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.13.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 8f50eb39a725..b9277da7e624 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,3 +1,4 @@
DIST pyproject_fmt-0.11.2.tar.gz 12134 BLAKE2B bff72bd12d41f9d9fa7cae82938f6cc921a079e966587a6432f07d17702835863f20e460003cc9321a8465c2e660b7474e0c9f54987b7ee7deaae99dd0e76b56 SHA512 2600212e4afcf238636c7b41a60e9a235a742a923fdcafcb174e08799845797d1813fc61ca56db9ada35def0deb94192180fe4ff15bb6cfa7208e1c1d3b339d0
DIST pyproject_fmt-0.12.0.tar.gz 13006 BLAKE2B 77581a51f4cf3885ce0e13ba91170406e9f757cf09bad251b5dfe38d209f9efcdaa9909d2d52b21106d5db021bce3e498e67bcf95011155955b821337e9f6e36 SHA512 98c6c8f95032d53f188a2cf85f477aaafdb94b59e3619aab155751f328ff309b959ffb1f1de9b613486486c98abd850396c891c04d5548c93931ead41d742503
DIST pyproject_fmt-0.12.1.tar.gz 13006 BLAKE2B 435f08e09ce6f28f33ac6b4a8701793622d1b118838babb7166e672776571beaeeeb2f2cc0cec95271abce678fa43f6ab03d616a3c6b86ad0ad3ea2feb3acdb0 SHA512 e48e73770f636f74b1e02b55e8bc3b76de110b72f1dd0f5a1c6d2616c8c64d4651bc99207b41524fce9d15443e69a8ffcc4f646a4aa5d56c515e9ce225391835
+DIST pyproject_fmt-0.13.0.tar.gz 13021 BLAKE2B 911925fb489782af9952cea68105ceeaa62fe96af130688f08892bc6fc701063f0a3b17c079323fd5358999f73fdffff59dbe910ca280cf9a963b2e45c10d22d SHA512 eb97893c9e04edd4667f961cb2232cda1be42f96ae94cd95886e70e48835b0228a0054bb4a75c439deff16990335ef56fbf60b8a0b2530d18856d075d42ff404
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.13.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.13.0.ebuild
new file mode 100644
index 000000000000..0770ee3966cf
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.13.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/natsort-8.3.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest