summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-05 09:50:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-05 11:13:51 +0100
commitbf5ff525268a5d5788e0496e5dc08fda32a508b2 (patch)
tree439e2687108bc79c63510d34848d55bb4234047d /dev-python/pyproj
parentsys-kernel/gentoo-kernel-bin: Re-fix newest bins (diff)
downloadgentoo-bf5ff525268a5d5788e0496e5dc08fda32a508b2.tar.gz
gentoo-bf5ff525268a5d5788e0496e5dc08fda32a508b2.tar.bz2
gentoo-bf5ff525268a5d5788e0496e5dc08fda32a508b2.zip
dev-python/pyproj: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/pyproj-3.0.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index acbd64e22bb9..46dcef39f4d6 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1 +1,2 @@
DIST pyproj-2.6.1.post1.tar.gz 545482 BLAKE2B ba87cbbe93dad357c1fc4f333c7d3f02b632e6f2a00821b3875e73965f36fd7ea958f24705c125c3ae43dc8edac1b53a20578c46bc55bcbf335a9457d193d493 SHA512 43a885dbbf4ba54839c3b697d2582700e2b30172ef34acf6297b5e4ddba9b3148aeab83b3a515f1ce975898828c77ad457b6f6460e91083189f66a2fde6d77b7
+DIST pyproj-3.0.1.tar.gz 168962 BLAKE2B 3271d604148c122f4dfdd68c4237e1911f30da7cc858128d644b6b6807c3e49450e0b42c385d37bbe1cfa5ab80d635e7f620d41bf5089af6b49a542eb9b3fcd0 SHA512 f5ae0ede1deaa93757cb98cc680d6e47a19b9f5c0ce5e357c2ecfe96f764ff59ec7285c606162da38573123d21f12f1df82354f1d2205149970af2d7d63c2689
diff --git a/dev-python/pyproj/pyproj-3.0.1.ebuild b/dev-python/pyproj/pyproj-3.0.1.ebuild
new file mode 100644
index 000000000000..7ea03bdd332b
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/pyproj4/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_p/.post}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND=">=sci-libs/proj-7.2.0:="
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # TODO
+ test/test_datum.py
+ test/test_transformer.py::test_transform_wgs84_to_alaska
+ test/test_transformer.py::test_repr__conditional
+ test/test_transformer.py::test_transformer_group__unavailable
+ test/test_transformer.py::test_transformer_group__network_disabled
+ test/test_transformer.py::test_transformer_group__download_grids__directory
+ test/crs/test_crs.py::test_coordinate_operation_grids__alternative_grid_name
+ )
+
+ distutils_install_for_testing
+ pytest -vv --import-mode=append -m "not network" \
+ ${deselect[@]/#/--deselect } test ||
+ die "Tests failed with ${EPYTHON}"
+}