summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-22 05:44:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-22 05:44:23 +0100
commitf762fb5288bd0874c8e73239d84f1fdcfc5a200a (patch)
tree9311f0e73ddab8a7eaa12625abe5a888949d09d5 /dev-python/pyghmi
parentdev-python/ensurepip-setuptools: Bump to 67.4.0 (diff)
downloadgentoo-f762fb5288bd0874c8e73239d84f1fdcfc5a200a.tar.gz
gentoo-f762fb5288bd0874c8e73239d84f1fdcfc5a200a.tar.bz2
gentoo-f762fb5288bd0874c8e73239d84f1fdcfc5a200a.zip
dev-python/pyghmi: Bump to 1.5.58
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.58.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 7c71afeb7e67..80bc2937024d 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.57.tar.gz 249816 BLAKE2B 358f5f5262c0bd59da668d590d36f4b84ef55fca78908a5fbfb6fead2cd652d704feaf73410906fcf969fab88928dd480ae1afa60e342663503630b57226a444 SHA512 d9fa87e2a715cb899c36f27e8c706d3330de488e0685e547bbed77c320ea824bed776276e936789e887b324e85899ae944a55d3549def3767d77ec789ddba42f
+DIST pyghmi-1.5.58.tar.gz 251278 BLAKE2B e4e019d7611b1f9464d7557937fdf3a3aa67649790825f5ad8958c36760fc4f651f7922de27694e2048abc3a6269d9237d9ee1662fa9682d15e9e8d9cacdc072 SHA512 88b2c23ceb45bc7460dd7adea600b296e92755dea63a0de86108e9e54131b40b06947ee5fb74587a60cb1cd2aed03cea126643c476299a30f27490c8cd5d9f30
diff --git a/dev-python/pyghmi/pyghmi-1.5.58.ebuild b/dev-python/pyghmi/pyghmi-1.5.58.ebuild
new file mode 100644
index 000000000000..7b3d2e7d3897
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.58.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest