summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-21 19:14:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-21 22:17:35 +0200
commit05e5c229a0916a43b3200731495006bd2a021446 (patch)
treea8fe6743ae643b5c00dfd19859ecd1dc2a960cdd /dev-python/pyfakefs/pyfakefs-4.6.3.ebuild
parentdev-python/aesara: Bump to 2.7.8 (diff)
downloadgentoo-05e5c229a0916a43b3200731495006bd2a021446.tar.gz
gentoo-05e5c229a0916a43b3200731495006bd2a021446.tar.bz2
gentoo-05e5c229a0916a43b3200731495006bd2a021446.zip
dev-python/pyfakefs: Bump to 4.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-4.6.3.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-4.6.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-4.6.3.ebuild b/dev-python/pyfakefs/pyfakefs-4.6.3.ebuild
new file mode 100644
index 000000000000..54098f2af2c1
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-4.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/jmcgeheeiv/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}