summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 08:46:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-02 09:50:40 +0200
commit2a2a7b479af5b89500c40bd0a4c2c2209d714ecb (patch)
tree5addff4a0e01cc85d9c3e890d53f6f3694d73cf2 /dev-python/pydata-sphinx-theme
parentdev-python/Faker: Bump to 8.14.1 (diff)
downloadgentoo-2a2a7b479af5b89500c40bd0a4c2c2209d714ecb.tar.gz
gentoo-2a2a7b479af5b89500c40bd0a4c2c2209d714ecb.tar.bz2
gentoo-2a2a7b479af5b89500c40bd0a4c2c2209d714ecb.zip
dev-python/pydata-sphinx-theme: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydata-sphinx-theme')
-rw-r--r--dev-python/pydata-sphinx-theme/Manifest1
-rw-r--r--dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pydata-sphinx-theme/Manifest b/dev-python/pydata-sphinx-theme/Manifest
index af3e43579ef1..db0e56e4ab10 100644
--- a/dev-python/pydata-sphinx-theme/Manifest
+++ b/dev-python/pydata-sphinx-theme/Manifest
@@ -1 +1,2 @@
DIST pydata-sphinx-theme-0.6.3.tar.gz 2617286 BLAKE2B caac09add734ab3127461f3b54069cf9bbb22b00b54e6d0ed999ff6d7783f68d2d97bf31d19ce99bdefa0e1d754e6194e5ead8347d89c5d704dc38e148fff619 SHA512 0106accc2f7b64899d09d1da5b39fccd074732c07db78a924aceb403923b3d67cdc0592834211ab1fcc2788ef55616da63e9eb058a7909b2486006061b6d367b
+DIST pydata-sphinx-theme-0.7.0.tar.gz 2632049 BLAKE2B 0226c06c31703518cfe570514ac2332a43db189b2044218d9135e33f3509f995835ed51b401d52e5ce4e4ca779a4cb98eea1e1966ed66199bdef2b84184ee8da SHA512 0f5d4647e35e4a74d0c64e24fa8aa6d1ba98a76218d8ebc9c96c9bb0c6336ff78f0fcc9f6d5191ce0b8d7707ca5069c89fc263ab85448e574f12b25fa3cdcc4a
diff --git a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.0.ebuild b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.0.ebuild
new file mode 100644
index 000000000000..66be2db1eeeb
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap-based Sphinx theme from the PyData community"
+HOMEPAGE="https://github.com/pydata/pydata-sphinx-theme"
+SRC_URI="https://github.com/pydata/pydata-sphinx-theme/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+"
+
+# TODO: fix this: Sandbox violation to /usr/local/share
+#distutils_enable_sphinx docs dev-python/commonmark dev-python/recommonmark dev-python/numpydoc dev-python/jupyter-sphinx dev-python/plotly dev-python/xarray
+distutils_enable_tests pytest