summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-02 22:10:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-02 23:01:29 +0200
commit715ecac89f1be51a619da14c3c6a674146ee8ea0 (patch)
treefa831c0f284b8dead2fa1f23c4421d1c48f5100f /dev-python/pycurl-requests/pycurl-requests-0.2.1.ebuild
parentdev-python/Faker: Bump to 8.9.1 (diff)
downloadgentoo-715ecac89f1be51a619da14c3c6a674146ee8ea0.tar.gz
gentoo-715ecac89f1be51a619da14c3c6a674146ee8ea0.tar.bz2
gentoo-715ecac89f1be51a619da14c3c6a674146ee8ea0.zip
dev-python/pycurl-requests: Bump to 0.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycurl-requests/pycurl-requests-0.2.1.ebuild')
-rw-r--r--dev-python/pycurl-requests/pycurl-requests-0.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pycurl-requests/pycurl-requests-0.2.1.ebuild b/dev-python/pycurl-requests/pycurl-requests-0.2.1.ebuild
new file mode 100644
index 000000000000..f08e2f6638e1
--- /dev/null
+++ b/dev-python/pycurl-requests/pycurl-requests-0.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Requests-compatible interface for PycURL"
+HOMEPAGE="https://github.com/dcoles/pycurl-requests"
+SRC_URI="https://github.com/dcoles/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # network-sandbox
+ pycurl_requests/tests/test_requests.py::test_get_connect_timeout
+ pycurl_requests/tests/test_requests.py::test_get_connect_timeout_urllib3
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}