summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-28 21:45:14 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-28 23:27:14 +0200
commite35bb26452e08af2d8cc652ec305ee19bf4e052b (patch)
treec449d294417cb0e4d780282977e403ecbf1b16f6 /dev-python/py2neo
parentdev-python/pbkdf2: Tested on py3.5 & py3.6 (diff)
downloadgentoo-e35bb26452e08af2d8cc652ec305ee19bf4e052b.tar.gz
gentoo-e35bb26452e08af2d8cc652ec305ee19bf4e052b.tar.bz2
gentoo-e35bb26452e08af2d8cc652ec305ee19bf4e052b.zip
dev-python/py2neo: Add setuptools dependency
Diffstat (limited to 'dev-python/py2neo')
-rw-r--r--dev-python/py2neo/py2neo-2.0.9.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/py2neo/py2neo-2.0.9.ebuild b/dev-python/py2neo/py2neo-2.0.9.ebuild
index 50dad8ea8d77..27257d606370 100644
--- a/dev-python/py2neo/py2neo-2.0.9.ebuild
+++ b/dev-python/py2neo/py2neo-2.0.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,6 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
python_compile() {
# https://github.com/nigelsmall/py2neo/issues/380
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"