summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-15 08:18:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-15 08:32:06 +0200
commitf791e9b28a5d721a4febe443b83d59e3be349f54 (patch)
tree56e270e73414c3dbfce01a74823e88140de3a4e6 /dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild
parentdev-python/xxhash: Bump to 2.0.2 (diff)
downloadgentoo-f791e9b28a5d721a4febe443b83d59e3be349f54.tar.gz
gentoo-f791e9b28a5d721a4febe443b83d59e3be349f54.tar.bz2
gentoo-f791e9b28a5d721a4febe443b83d59e3be349f54.zip
dev-python/py-cpuinfo: Bump to 8.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild')
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild
new file mode 100644
index 000000000000..944389530103
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-8.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="
+ https://github.com/workhorsy/py-cpuinfo/
+ https://pypi.org/project/py-cpuinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests setup.py