summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-25 04:37:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-25 04:55:00 +0200
commite099f28acf7eaed1fb50e531dd3057bca0912151 (patch)
treebbabd5617ddd9b51181a6e931868cc2a40c8b805 /dev-python/prometheus-client
parentdev-python/prometheus_client: Switch to pypi sdist (diff)
downloadgentoo-e099f28acf7eaed1fb50e531dd3057bca0912151.tar.gz
gentoo-e099f28acf7eaed1fb50e531dd3057bca0912151.tar.bz2
gentoo-e099f28acf7eaed1fb50e531dd3057bca0912151.zip
Rename dev-python/{prometheus_client → prometheus-client}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prometheus-client')
-rw-r--r--dev-python/prometheus-client/Manifest1
-rw-r--r--dev-python/prometheus-client/metadata.xml13
-rw-r--r--dev-python/prometheus-client/prometheus-client-0.16.0.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/prometheus-client/Manifest b/dev-python/prometheus-client/Manifest
new file mode 100644
index 000000000000..0117eb3715f8
--- /dev/null
+++ b/dev-python/prometheus-client/Manifest
@@ -0,0 +1 @@
+DIST prometheus_client-0.16.0.tar.gz 117546 BLAKE2B 6b4e6600b352f17620e432edd976c2d26ef71326018bd1fa81f6bf4842f1599b06b11036a3b71c641698ad3d1e2f4422812133b51a34ecc70ec0606e9ea2478c SHA512 12d22963a22511872fbd170e112a743fac02ab1a569934eef5d97f53a292281ef3f589e852f245d083d8555c5cda51c6210fe48e1211431c8fe00b47d571eaf4
diff --git a/dev-python/prometheus-client/metadata.xml b/dev-python/prometheus-client/metadata.xml
new file mode 100644
index 000000000000..705228750c76
--- /dev/null
+++ b/dev-python/prometheus-client/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">prometheus/client_python</remote-id>
+ <remote-id type="pypi">prometheus-client</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/prometheus-client/prometheus-client-0.16.0.ebuild b/dev-python/prometheus-client/prometheus-client-0.16.0.ebuild
new file mode 100644
index 000000000000..d13ab19b83f7
--- /dev/null
+++ b/dev-python/prometheus-client/prometheus-client-0.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://github.com/prometheus/client_python/
+ https://pypi.org/project/prometheus-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest