summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-21 16:58:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-21 17:01:31 +0200
commit4a4e2d22c612a23cc3b27685b28cc75b245d8171 (patch)
tree207a925830c36ec48a4e4b60d132d521a12f8c17 /dev-python/pluggy
parentdev-libs/c-blosc2: Bump to 2.9.3 (diff)
downloadgentoo-4a4e2d22c612a23cc3b27685b28cc75b245d8171.tar.gz
gentoo-4a4e2d22c612a23cc3b27685b28cc75b245d8171.tar.bz2
gentoo-4a4e2d22c612a23cc3b27685b28cc75b245d8171.zip
dev-python/pluggy: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-1.2.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index d3872f4fda14..685254e59621 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1,2 +1,3 @@
DIST pluggy-1.0.0.tar.gz 51510 BLAKE2B 8107df9a91a843166a602e7518dd1d4167304464a8cc80180b60b03a2ac803be9b1ba190df9189907addd34a92b93a6b271d3d6b7485aa563203ce733c6a656c SHA512 cf0bcbb4330c24ce473614befa19548f33fb39fa0ad094e1eae786202d7adadc28e16499f80ab96b630091765404ca5c5b6f9a55bc605e03514d8ab50cf9ae00
DIST pluggy-1.1.0.tar.gz 59984 BLAKE2B 58dacd5b11e7817f1f4923bcaaa8739c46972b9937b865660d6ae85019582fc9d596b5ab113884925ebb566756aeccd698e2c910a50238e81eda2f413686b8e3 SHA512 3cf95fd78f53525bccf04bc6dfc5101f942bdc3e787ea7c9369c6b2198e014c661999dd64ccce729787d080f44885720e25edd78bac0b93054450e09ff00b7d7
+DIST pluggy-1.2.0.tar.gz 61613 BLAKE2B f1c9d7ca593cd3eaae2f035c8e2d2da09b179991a134e0c0be17642940a853194124b638e208c32b7f8e5250d30d138f4bb79cb414573c0103e6b5024f52abc9 SHA512 b2b6a80737c06e1507eb12513ed7f5ce508fd4a139c559a3a15d9f173f4455ef3847783efb91c32eca6e26cbe37b0336467d50c5db0563d8dbd17bd825cd7407
diff --git a/dev-python/pluggy/pluggy-1.2.0.ebuild b/dev-python/pluggy/pluggy-1.2.0.ebuild
new file mode 100644
index 000000000000..dd354f8f296d
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin and hook calling mechanisms for Python"
+HOMEPAGE="
+ https://pluggy.readthedocs.io/
+ https://github.com/pytest-dev/pluggy/
+ https://pypi.org/project/pluggy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest