summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-11 07:02:40 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-11 07:55:53 +0100
commit023212d0159baa8cb8797afe3778963500c8f2d4 (patch)
tree1b6e927f6d7be41f15cbf7456d4bda0480d0d29f /dev-python/platformdirs
parentdev-python/sphinx-gallery: Bump to 0.12.2 (diff)
downloadgentoo-023212d0159baa8cb8797afe3778963500c8f2d4.tar.gz
gentoo-023212d0159baa8cb8797afe3778963500c8f2d4.tar.bz2
gentoo-023212d0159baa8cb8797afe3778963500c8f2d4.zip
dev-python/platformdirs: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-3.1.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index db96a879ab49..816e2bafd306 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,3 +1,4 @@
DIST platformdirs-2.6.2.gh.tar.gz 21184 BLAKE2B 4acc85301f764d4457ace88f9fb409e4d2f8bb17b9133dc3316c4d265a7cf50019298f1ba4cef87f5999b48fd7060687f7008079de26ffe74740a4cefff9309e SHA512 704cc39ba1746055e0459139759e118bd6178fb13cc8ecf580f58d16073fbb8ade0bce8b5eb9230ccc45b19f622a41c84a06f8698ee722da9d5cec44c5f46e25
DIST platformdirs-3.0.0.gh.tar.gz 21358 BLAKE2B b7dd6d55cc07d9e584d2e3f4a8a1e3bcd5b75eac6786c4225c9b249af9d98cbe0c8b1edc7a6180c147ad13d0a7d5c4fbc9f15cf71af03590c011f7fd4ae336a4 SHA512 36885fdb4767e2525eef48e8ede6cec8013d2e8767c7940381d642faa14382583885c2428ce7b27fc36d33048494354cb4d16b42eac2748ca4458b8c124ed01f
DIST platformdirs-3.1.0.gh.tar.gz 21721 BLAKE2B 5f7334c0003d0dcd51473820239068dd441ecc18e7837822f824f8ca2e5f5915aa89363eee27740214b97c1c4bb258a4ffa2ab6b4963bf6e9346c13fed6dc0f0 SHA512 49ad7b15419aff2c5af5c63a8850378d688eb95aadcd0c489d26fe4eea8315caffb17136fa7cbdf4a945bebae2eb8154ddfb771ed6fdc47595eff590e0f32ccb
+DIST platformdirs-3.1.1.gh.tar.gz 21773 BLAKE2B e0e9f8d2387f3b391feb926c478852c1e189ce89ab4fb5731b95b619047c77ac0ea5209a3a64ca85ba8479552aab753900fa8ca0b7b3f1051f7f29a2cc7841aa SHA512 32929363c3d9d0589d13f3b4447fe2a77e72e0ed28dd61d6a4fc627f2064e130134fe98f07b915fa148e1066f4db0869b8aa064775aa6ff61810c87f7f084916
diff --git a/dev-python/platformdirs/platformdirs-3.1.1.ebuild b/dev-python/platformdirs/platformdirs-3.1.1.ebuild
new file mode 100644
index 000000000000..b876a13536e6
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-3.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}