summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-16 00:37:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-16 00:38:48 -0500
commit1d303296072073839ff7092464e9cae112e6ef30 (patch)
tree62dc304e09b4e6038fd839e8cdc3e584e1c93246 /dev-python/pecan
parentmedia-libs/libsdl: Stable for HPPA (bug #562978). (diff)
downloadgentoo-1d303296072073839ff7092464e9cae112e6ef30.tar.gz
gentoo-1d303296072073839ff7092464e9cae112e6ef30.tar.bz2
gentoo-1d303296072073839ff7092464e9cae112e6ef30.zip
dev-python/pecan: actually liberty this time
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/pecan')
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.0.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index 69cf681e23f9..78b52be85829 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1 +1,2 @@
+DIST pecan-1.0.2.tar.gz 206278 SHA256 09ec440bd20821ba1170667ce9994712701416eaa6044cfe7c647aa5e291c5bd SHA512 af680881f37c4b489c0dcf58786f1a49a172921bb534e8b54dced794b0d2097f2c29d0ba11b740affd85756eb244afc465d20023295ec4fbb857371c63199ddb WHIRLPOOL 9ff31797ef3e3c0123f0aaf990dfc646dc65d7f4887d36c2190e80f8b1cb5f0bf52068c9d467c05b939ac17c571224dde2f0ca5d00bd1f757f0834184a705383
DIST pecan-1.0.3.tar.gz 119309 SHA256 8d6c99709a9e0ba0752b23e0b4759b7b33e8d8650ee45c1f5f5fa2a596af4b11 SHA512 f1ee856085d740afb60caebe73f9083aea3dcce9a0fbcb7cc5b93909014a01b9c3987c4dc241075578ab8d6e4798160cd393aacb1d783c2397b2fea6771de456 WHIRLPOOL 13da73b372905446e1e89827115e2201ae4e9e9a5fc1cf4e2c22c0ad875d17960d2224a59271048f196d4869ea21552cd3b6fefba7658534eff03b05df7ea36b
diff --git a/dev-python/pecan/pecan-1.0.2.ebuild b/dev-python/pecan/pecan-1.0.2.ebuild
new file mode 100644
index 000000000000..c679d7f1f7a3
--- /dev/null
+++ b/dev-python/pecan/pecan-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, designed to be lean and fast, with few dependencies."
+HOMEPAGE="https://pypi.python.org/pypi/pecan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"