summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-16 04:56:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-16 05:18:09 +0200
commit9c2b55f2a78b9db7d04c6c01cc80a247e1e2bf3c (patch)
treea65b71326cba1f94752fc787206d63171b8a300a /dev-python/oslo-serialization
parentdev-python/pydantic-core: Bump to 2.22.0 (diff)
downloadgentoo-9c2b55f2a78b9db7d04c6c01cc80a247e1e2bf3c.tar.gz
gentoo-9c2b55f2a78b9db7d04c6c01cc80a247e1e2bf3c.tar.bz2
gentoo-9c2b55f2a78b9db7d04c6c01cc80a247e1e2bf3c.zip
dev-python/oslo-serialization: Bump to 5.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-serialization')
-rw-r--r--dev-python/oslo-serialization/Manifest1
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-5.5.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/oslo-serialization/Manifest b/dev-python/oslo-serialization/Manifest
index 4488597d2813..90b520ae0918 100644
--- a/dev-python/oslo-serialization/Manifest
+++ b/dev-python/oslo-serialization/Manifest
@@ -1 +1,2 @@
DIST oslo.serialization-5.4.0.tar.gz 35070 BLAKE2B 2a6af45234083f57d964f18d36eb00b59ce6f32927fd93696bbfaa705b574a8c335db9583b2d6fb72d8b6712b1b5e6b30c943a4130b5ff3fc5766c3fce09e4a5 SHA512 00c9dae7cf254fe0fba49b25bb2d150902bd3a0a88cff922853358374bc855e8b79bef111065aaf62966c98a97605d0a0f18b5d007f36a943d9bdeb8ca69783b
+DIST oslo.serialization-5.5.0.tar.gz 35102 BLAKE2B 7ac9ef1d35c3f1a7396456bc9b29d8c3100d9c62e72e90dd9e75bfe27e7416bc9c31ed41155bd5197e95536400b409d7f878819535511b2c805d2bb4111ea880 SHA512 51043ae3d27c5a9dc482234a95a175722d56dc35294cb34845e8d34e6de5d1b49a16a1cd5c84a4d51b595be77c76e9bb322054f61d6e5e5948f8fc48a8dd3294
diff --git a/dev-python/oslo-serialization/oslo-serialization-5.5.0.ebuild b/dev-python/oslo-serialization/oslo-serialization-5.5.0.ebuild
new file mode 100644
index 000000000000..d14414d55783
--- /dev/null
+++ b/dev-python/oslo-serialization/oslo-serialization-5.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Serialization library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.serialization/
+ https://github.com/openstack/oslo.serialization/
+ https://pypi.org/project/oslo.serialization/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ dev-python/tzdata[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.2.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx doc/source \
+ dev-python/openstackdocstheme
+
+python_prepare_all() {
+ # remove spurious rdep on pbr
+ sed -i -e '/pbr/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}