summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-03-18 17:42:42 +0100
committerDavid Seifert <soap@gentoo.org>2023-03-18 17:42:42 +0100
commit96f18d1fb9e250cbfa3e2eb0d3129e5ee4d3b2d9 (patch)
treeb335cdd50fb9f961ac34811cb0f6b5e368ff3d92 /dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild
parentnet-misc/gsutil: treeclean (diff)
downloadgentoo-96f18d1fb9e250cbfa3e2eb0d3129e5ee4d3b2d9.tar.gz
gentoo-96f18d1fb9e250cbfa3e2eb0d3129e5ee4d3b2d9.tar.bz2
gentoo-96f18d1fb9e250cbfa3e2eb0d3129e5ee4d3b2d9.zip
dev-python/oauth2client: treeclean
Closes: https://bugs.gentoo.org/733064 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild')
-rw-r--r--dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild b/dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild
deleted file mode 100644
index f17e9279839b..000000000000
--- a/dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
-HOMEPAGE="https://github.com/googleapis/oauth2client"
-SRC_URI="https://github.com/googleapis/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${P/_p/-post}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests nose
-
-PATCHES=(
- "${FILESDIR}/oauth2client-4.1.3-py38.patch"
-)
-
-python_test() {
- nosetests -v \
- -e appengine \
- -e django_util \
- -e test_multiprocess_file_storage \
- -e test_bad_positional || die "tests fail with ${EPYTHON}"
- # appengine - requires appengine
- # django_util - requires django
- # test_multiprocess_file_storage - requires fasteners
- # test_bad_positional - expects TypeError, gets ValueError
-}