summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-01 08:24:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-01 09:21:28 +0200
commitf3dceeeaf6b273a4e93a22f7c19e5bb27146bbb2 (patch)
tree2e802985a9630d808f83b514f1e540bf34520361 /dev-python/nbclient
parentmedia-libs/alsa-lib: Removed old (diff)
downloadgentoo-f3dceeeaf6b273a4e93a22f7c19e5bb27146bbb2.tar.gz
gentoo-f3dceeeaf6b273a4e93a22f7c19e5bb27146bbb2.tar.bz2
gentoo-f3dceeeaf6b273a4e93a22f7c19e5bb27146bbb2.zip
dev-python/nbclient: Bump to 0.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.6.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index f4554ea5a041..92b1d75eca1a 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -2,3 +2,4 @@ DIST nbclient-0.5.13.gh.tar.gz 75335 BLAKE2B 02a1d7d84b51c3af81f4d511e3a68a94d28
DIST nbclient-0.6.0.gh.tar.gz 76454 BLAKE2B a6b9f829d4d67f18d489d913000d6507d988ba2e88a0a63c1e750941fa24d071b4c711f1bf2f8af154b62b853378c9c1a97426d8b4082bf6911be1da6935cb26 SHA512 3e986b44ebafde75b95042fc32f38d152487b5ce3a62aac4a41eca27c35d24c795c4dd0e694a9f211d06bc37ea4f76959ce30ebb8a19e04ed4ffafd5b8f1a4a1
DIST nbclient-0.6.2.tar.gz 77390 BLAKE2B 0281b8fdfb01f31f2a1b9ed4b85b4dae1f3becc4afce29bb4359291840cf0dd69ee8acc97872e7c7e532c337d3a41a5d694b3ba644883f11ccf503439216eafa SHA512 878657911f30ae573a42f5a85d5e6359b32ae1aed178491912a51947677263137ce8ab7de0a34bb149a2fd4aab872c34977eb6ce1c77701ebfd1082b60576dd5
DIST nbclient-0.6.3.tar.gz 77571 BLAKE2B 41b96f8c174506a97b257b352e2614f023785137bf79d57d9bd4fd38942b54cc9db97bdf63c65579e67f88afd57ff81cbc798880080842e981797ee07be9f441 SHA512 bf267f3f49289cadcce412dc772f01dab5cd4d5a4ceb3fa12b076357d04191a15573d540773d47d58a14570fe219a9591ab539b917b52f3f7a902aac0493ba82
+DIST nbclient-0.6.4.gh.tar.gz 78101 BLAKE2B 91a653eb1735fe1a43044f18da773bcb0c4afd485fe7bfd3630c8c6a80776c9ff7e4cb08130c4e3953f03832933c429e68d7383677d8e56c54b485d55b8c5469 SHA512 a953b40b314ce104b28dfb9178a004ca4726d8a5912c84c168bf71527ee224082d3910f11040b172b6e62683493978b9b10161b69cadbca48a5652a4f98b5009
diff --git a/dev-python/nbclient/nbclient-0.6.4.ebuild b/dev-python/nbclient/nbclient-0.6.4.ebuild
new file mode 100644
index 000000000000..cc41ec1e5d49
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.6.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.5[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)