summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 09:31:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 09:33:58 +0100
commit259c5bdb99ded241c7bf4aa15b4ce787abc59b0f (patch)
treedbbb3bdca41360a2f7857d37d04efe167eecf1e7 /dev-python/mysql-connector-python
parentdev-python/mysqlclient: Remove redundant versions (diff)
downloadgentoo-259c5bdb99ded241c7bf4aa15b4ce787abc59b0f.tar.gz
gentoo-259c5bdb99ded241c7bf4aa15b4ce787abc59b0f.tar.bz2
gentoo-259c5bdb99ded241c7bf4aa15b4ce787abc59b0f.zip
dev-python/mysql-connector-python: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest2
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-2.1.7-r1.ebuild37
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.18.ebuild52
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index 3cf07992e250..c76e5529f6b0 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,3 +1 @@
-DIST mysql-connector-python-2.1.7.tar.gz 11781659 BLAKE2B 332092059a32249e449f99540beb9eebf80e9381cef4560208412a19385894eb2193f02d5a20aceafe9644b8a225926a02d57c3acc89ba7d321b6d0f9c7c4d76 SHA512 f88c3a6dd3c3c1cd5c16165daef801dbcc7ea9163406273dd751e25687a57dcdf4ffbcdb65bb107e8cd9d7c91029823f625dc19ab34116398263fa074598880a
-DIST mysql-connector-python-8.0.18.tar.gz 12037201 BLAKE2B 54dc45c9ecc09bad755bafec2b3b73e35368f742f30c8644764c8c892c6f79c3b6b438cf38dd9ebc878cd76d5d74d71be6668a903b57b3d0feaba9ff6f5b58cc SHA512 cb441a6388de8609b56e4d9885ae2491d207c7b1e3bb387341d55853d383eff6e268e34feb32b42797c7b210d35f9d6dbc302ea4c9ed2441a76b91ea66d504b2
DIST mysql-connector-python-8.0.19.tar.gz 12051609 BLAKE2B 252d4ee650c1eddbe54575451ac378236b6a795237c445239ecec096c7adcb60da2244592f083a50df57c9e2ae6447f1dcaf861042973a31c3fe7292509ef93d SHA512 9137b0b6aafbff16c83f59ab03da810232a92f6b76e38f460782153c5ddbdf6ae55d0c72a0c7902b7bc05ad1010bdc849662cd3d2138ae93476abf013e7a508f
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-2.1.7-r1.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-2.1.7-r1.ebuild
deleted file mode 100644
index 101dc7922036..000000000000
--- a/dev-python/mysql-connector-python/mysql-connector-python-2.1.7-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt docs/README_DOCS.txt )
-
-python_test() {
- "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples ; then
- dodoc -r examples
- fi
-}
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.18.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.18.ebuild
deleted file mode 100644
index bb4fd728f8e4..000000000000
--- a/dev-python/mysql-connector-python/mysql-connector-python-8.0.18.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-BDEPEND=">=dev-libs/protobuf-3.6.1"
-
-RDEPEND="
- >=dev-db/mysql-connector-c-8.0
- >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
-"
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt README.rst )
-
-python_test() {
- "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
-}
-
-# Yeah, this is really broken, but the extension will only build this way during "install"
-python_install() {
- distutils-r1_python_install \
- --with-mysql-capi="${EPREFIX}/usr" \
- --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
- --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --with-protoc="${EPREFIX}/usr/bin/protoc"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples ; then
- dodoc -r examples
- fi
-}