summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-15 03:56:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-15 05:04:41 +0200
commitbeab25960f809580691c78d8817229003b1a30a9 (patch)
treedf50c89edbc50b4189245da28c0c3cade01e9e1a /dev-python/mkdocstrings-python
parentdev-python/zipp: Bump to 3.16.2 (diff)
downloadgentoo-beab25960f809580691c78d8817229003b1a30a9.tar.gz
gentoo-beab25960f809580691c78d8817229003b1a30a9.tar.bz2
gentoo-beab25960f809580691c78d8817229003b1a30a9.zip
dev-python/mkdocstrings-python: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 79af110d7939..6078b73952ff 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1 +1,2 @@
DIST mkdocstrings-python-1.1.2.gh.tar.gz 127162 BLAKE2B 1aa77a6846b8f4787091691c3862428400cf73e5b51f3d7a278e9d871136a3693d80a1fe79d6999dedefe66b0a14402e0d70c448f9260c1528024a56cf223c69 SHA512 40c8247bc6217e73c23555fb3de14ddc8995e1870c7bcee85c12c885b9710cd303da3cec22b4ae44ff5de050486958447d2d489d9739b9860c432e9e00fec0d7
+DIST mkdocstrings-python-1.2.0.gh.tar.gz 132100 BLAKE2B 8873ea65a799f5f8d6bf4a792abb94edc70e8acb0140dfa30dda15d9d94e354fe4c32c99dde5c53c2c04af7591762c50c5c2cf4fb7a8e167e2065c6d6da0aba1 SHA512 f2e07ad52a5102b178a5bc9245c018319b52f37d11fdf1650f3568275fe7d7800938d699a2ef1c6343f21187d47b34b0374ddbfb0cc04891a462480533043f72
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild
new file mode 100644
index 000000000000..44a4ca132d47
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.30.0[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}