summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-15 09:23:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-15 09:36:02 +0300
commite3f85e95c09e729aa83b51239a40556830d3d6f5 (patch)
treef3aaf851f5e158bc553647a9514c9b01b639d41b /dev-python/mechanize/mechanize-0.4.8.ebuild
parentdev-python/botocore: add 1.24.41 (diff)
downloadgentoo-e3f85e95c09e729aa83b51239a40556830d3d6f5.tar.gz
gentoo-e3f85e95c09e729aa83b51239a40556830d3d6f5.tar.bz2
gentoo-e3f85e95c09e729aa83b51239a40556830d3d6f5.zip
dev-python/mechanize: add 0.4.8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mechanize/mechanize-0.4.8.ebuild')
-rw-r--r--dev-python/mechanize/mechanize-0.4.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/mechanize/mechanize-0.4.8.ebuild b/dev-python/mechanize/mechanize-0.4.8.ebuild
new file mode 100644
index 000000000000..910c92be7113
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="https://github.com/python-mechanize/mechanize"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ "${EPYTHON}" run_tests.py || die
+}