summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-10 09:00:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-10 09:24:07 +0200
commitd454d29d20600e94577d21a3989061c69eab829b (patch)
tree95cae25b6f2c3f16d7d3104b41f09ed1c28731d3 /dev-python/marshmallow
parentdev-python/marshmallow: Remove old (diff)
downloadgentoo-d454d29d20600e94577d21a3989061c69eab829b.tar.gz
gentoo-d454d29d20600e94577d21a3989061c69eab829b.tar.bz2
gentoo-d454d29d20600e94577d21a3989061c69eab829b.zip
dev-python/marshmallow: Bump to 3.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.12.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 8496e66103d9..b7c12afe777e 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.11.1.tar.gz 173844 BLAKE2B edd816ccd254dc52e01a2e067ff3037fa5206ae5badb1e9b46d83d3bdcd926d324c39321e4fa2b4fdf276158d36c2d3634086f76086dececaa24213bbb765e42 SHA512 ebb6b20ffc1b199408ede0c88d1512cada14cf7220315100398137b8374940c03dda2e6449ab9135963598ab321669068a9eca0e1c4cd2f3f2454eba19db04bd
+DIST marshmallow-3.12.0.tar.gz 174790 BLAKE2B 07539540f361137dd2fa2d5c884e279137a82f69e8a9e294d6abe4c566c98f74a1836018618682ac0a08f1e0d1510dbffa6d9c030a98e2cba48230697742b7e3 SHA512 7b91ec42dffbb979bede21fbab17cfb081068eea54d02aaef991b58e884cc5675fb17d5f56278794e5c33960bf29951ba74533abb9a025228a524a4e413bd312
diff --git a/dev-python/marshmallow/marshmallow-3.12.0.ebuild b/dev-python/marshmallow/marshmallow-3.12.0.ebuild
new file mode 100644
index 000000000000..9f52e6654547
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.12.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest