summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-23 17:30:01 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-24 21:03:44 +0200
commit13ea51202f971c357987d7d093a6899ab05b842c (patch)
treef6ca6aff19fbcb8839d054eb90e759f84259cbd3 /dev-python/lit
parentsys-devel/llvm-common: Branch for 5.0.0 release (diff)
downloadgentoo-13ea51202f971c357987d7d093a6899ab05b842c.tar.gz
gentoo-13ea51202f971c357987d7d093a6899ab05b842c.tar.bz2
gentoo-13ea51202f971c357987d7d093a6899ab05b842c.zip
dev-python/lit: Branch for 5.0.0 release
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-5.0.9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/lit/lit-5.0.9999.ebuild b/dev-python/lit/lit-5.0.9999.ebuild
new file mode 100644
index 000000000000..61b9ce3ec021
--- /dev/null
+++ b/dev-python/lit/lit-5.0.9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_50"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+S=${WORKDIR}/${P}/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+python_test() {
+ ./lit.py -sv tests || die
+}