summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 06:41:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 07:21:23 +0100
commitdfee81067f7eeb70811f68a018909312487d8757 (patch)
treea2be86da2ec8456cc9a70a9627cc35516b2d9784 /dev-python/jupyter_events
parentdev-python/traitlets: Bump to 5.8.1 (diff)
downloadgentoo-dfee81067f7eeb70811f68a018909312487d8757.tar.gz
gentoo-dfee81067f7eeb70811f68a018909312487d8757.tar.bz2
gentoo-dfee81067f7eeb70811f68a018909312487d8757.zip
dev-python/jupyter_events: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_events')
-rw-r--r--dev-python/jupyter_events/Manifest1
-rw-r--r--dev-python/jupyter_events/jupyter_events-0.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jupyter_events/Manifest b/dev-python/jupyter_events/Manifest
index 2f0669a0a419..484724a9b156 100644
--- a/dev-python/jupyter_events/Manifest
+++ b/dev-python/jupyter_events/Manifest
@@ -1 +1,2 @@
DIST jupyter_events-0.5.0.tar.gz 55838 BLAKE2B a3ac815a28d2592a10394569726b76de75cb3baab0bab4c1f276da33375ba93d6bfed71fbfaca404a238b7af58ebd7e75dd7fdf6c8717141517c2f790eeb9514 SHA512 49c21f0d5dce18b137f73911b0272919a56c972561deceb228558ea369f2091ce219ac335eec002b22ca1465b2622330fb3d8973d142df4b76e350345cb6249a
+DIST jupyter_events-0.6.0.tar.gz 58712 BLAKE2B 36c72bb978ff20b24d0633da16c5ce52da3766c5ef5e707d680a8c0e3b63eb5e51d02ddff787303d3b558896c3b1276c2c78ac6dd631758e770f530a396ca34f SHA512 b3c2b0ba3183692cf1d958c12ede11f4a01a28a5c85e89f4186361927bf2529354b7f632a7f69848ad69dbdd2d554e2baff3dcef768582e67bd1f59bab48b9a8
diff --git a/dev-python/jupyter_events/jupyter_events-0.6.0.ebuild b/dev-python/jupyter_events/jupyter_events-0.6.0.ebuild
new file mode 100644
index 000000000000..6716f49191f4
--- /dev/null
+++ b/dev-python/jupyter_events/jupyter_events-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_events/
+ https://pypi.org/project/jupyter-events/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest