summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-22 19:47:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-22 19:48:04 +0300
commit3ece46c6614f26372fe166fc6f20778f677029f8 (patch)
tree4b38935fef68c03a6167ad7b9ec4d058d55222c4 /dev-python/jupyter_console
parentapp-arch/bzip3: drop old 1.1.1-r1 (diff)
downloadgentoo-3ece46c6614f26372fe166fc6f20778f677029f8.tar.gz
gentoo-3ece46c6614f26372fe166fc6f20778f677029f8.tar.bz2
gentoo-3ece46c6614f26372fe166fc6f20778f677029f8.zip
dev-python/jupyter_console: add 6.4.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_console')
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.4.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
index a0d0b7e97004..4c135d1abdf5 100644
--- a/dev-python/jupyter_console/Manifest
+++ b/dev-python/jupyter_console/Manifest
@@ -1 +1,2 @@
DIST jupyter_console-6.4.3.tar.gz 35432 BLAKE2B 57af0ccba4730e445972a937e9e103695dc33387c5aa15239416c280f79259963119a3485526d00beb92b7b11c579f68542dcbac39e0d625b3a592a82e8bdcbb SHA512 6b8f9be62efdac9d8a17367e169f8f73c3d7ee2783692ea380853a886d228957cad03095a2aa165a1ace3440c340e2939c1044c85fa3f5e1e2d1f48919e562da
+DIST jupyter_console-6.4.4.tar.gz 35145 BLAKE2B d37190c30eceba79c0d37ad60d88c9e691759aaccb29a64a9482b7c3cf3315efa3c902ac2244c2139ef2f94a77450115124227768f8291f73512796aaff1214a SHA512 1f06591ed2a0fcf56e783d4e9f2a7c3f58a4f566cfb63b3367edac23c7709aa1af7bf6639c7358227a987049804da90658144fa5ad38db120c0816e78ed465ef
diff --git a/dev-python/jupyter_console/jupyter_console-6.4.4.ebuild b/dev-python/jupyter_console/jupyter_console-6.4.4.ebuild
new file mode 100644
index 000000000000..6f70ca03cce9
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-7.0.0[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-3.1.0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest