summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 09:11:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 09:33:39 +0100
commit17c9c365f18205a318a09f87aecd2dbd7f93faec (patch)
tree7e7492774d6bf9b44eadda5cc582c4bac517c5bb /dev-python/jupyter
parentdev-libs/qtkeychain: Add missing dep on libsecret (diff)
downloadgentoo-17c9c365f18205a318a09f87aecd2dbd7f93faec.tar.gz
gentoo-17c9c365f18205a318a09f87aecd2dbd7f93faec.tar.bz2
gentoo-17c9c365f18205a318a09f87aecd2dbd7f93faec.zip
dev-python/jupyter: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/jupyter/jupyter-1.0.0-r1.ebuild b/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
deleted file mode 100644
index 816b444bd17b..000000000000
--- a/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
- "
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/qtconsole[${PYTHON_USEDEP}]
- dev-python/jupyter_console[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
-
-PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
- distutils-r1_python_install_all
-}