summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-17 09:42:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-17 09:43:33 +0200
commit94ca702e05e2b7003192ccf0f5fbbed9ea5fd9b2 (patch)
tree3abff02ceaa32a0d653a42550953124ae45e9dd6 /dev-python/jsonschema
parentapp-portage/gemato: Bump to 14.4 (diff)
downloadgentoo-94ca702e05e2b7003192ccf0f5fbbed9ea5fd9b2.tar.gz
gentoo-94ca702e05e2b7003192ccf0f5fbbed9ea5fd9b2.tar.bz2
gentoo-94ca702e05e2b7003192ccf0f5fbbed9ea5fd9b2.zip
dev-python/jsonschema: Backport test-dep on twisted
Closes: https://bugs.gentoo.org/719806 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/jsonschema-3.0.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/jsonschema/jsonschema-3.0.1.ebuild b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
index 2831d238932f..f3875be46edf 100644
--- a/dev-python/jsonschema/jsonschema-3.0.1.ebuild
+++ b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit distutils-r1
@@ -33,7 +33,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-python/vcversioner-2.16.0.0[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )"
python_test() {
"${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"