summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 12:44:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 14:18:20 +0100
commita75d8ca1daf6c202af7e96e2f14507bb4e1386e4 (patch)
tree013f38578833a5c34987c26e4049374ad25c78ac /dev-python/jsonschema-spec
parentdev-python/pyglet: Bump to 2.0.4 (diff)
downloadgentoo-a75d8ca1daf6c202af7e96e2f14507bb4e1386e4.tar.gz
gentoo-a75d8ca1daf6c202af7e96e2f14507bb4e1386e4.tar.bz2
gentoo-a75d8ca1daf6c202af7e96e2f14507bb4e1386e4.zip
dev-python/jsonschema-spec: Bump to 0.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest1
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index 3d81a4c468e4..7c4410d0a9db 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1 +1,2 @@
DIST jsonschema-spec-0.1.2.gh.tar.gz 21782 BLAKE2B 238f035e75ec45edade5fd00269d2fc208a73208d1e07586490728b8c97819d6fddd9b909d2af00e63ebc4c141cb8dbaaf8e3e7ce88c3ff58ada2ba147c1e2c9 SHA512 0cba83a14e88d4fe2fcce9e4d39fa4284f23366a1f8acab16fa4b7b824d0c02bf04429d61c51a39a7a188c4e2b79f4481bba14ca688edee71beb0060e16617e0
+DIST jsonschema-spec-0.1.3.gh.tar.gz 30794 BLAKE2B 545eda0aef433eb62cd02bbcc4d07469b26c477bbf572d71bcb4eb126acc5ab912f5f80c0699305b37f7f526f36910bcb019d66a763e679846bb20a5b01eb813 SHA512 95465c43b842289ed28dd78ec06614d77b2bbf7d9d69e5dc4b89008740d0cc85e5b3319acd66d0142b533425e8f150c4edbbf15b7f8e3bdefb28b81193a13432
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild
new file mode 100644
index 000000000000..99f4c3f182b5
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}