summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 07:35:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:40:10 +0200
commita634ae686e72301ad0b954dc6a08f14f0f6cc53f (patch)
tree43900cb10340de10c25060cc046d7bfec9d0dccc /dev-python/jsonpickle
parentRename dev-python/{jschema_to_python → jschema-to-python} (diff)
downloadgentoo-a634ae686e72301ad0b954dc6a08f14f0f6cc53f.tar.gz
gentoo-a634ae686e72301ad0b954dc6a08f14f0f6cc53f.tar.bz2
gentoo-a634ae686e72301ad0b954dc6a08f14f0f6cc53f.zip
dev-python/jsonpickle: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/jsonpickle-3.0.2.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild b/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild
index 604267b17290..e09e79aa52f4 100644
--- a/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild
+++ b/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 optfeature
@@ -26,12 +26,14 @@ BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/gmpy[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
dev-python/ujson[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/gmpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ ' python3_{10..11})
)
"
@@ -53,6 +55,14 @@ python_test() {
# unpackaged bson dependency
tests/bson_test.py
)
+
+ if ! has_version "dev-python/gmpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=( jsonpickle/ext/gmpy.py )
+ fi
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=( jsonpickle/ext/pandas.py )
+ fi
+
epytest
}