summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-17 08:40:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-17 08:48:01 +0100
commit572bdd0aa7aad529ec9de1143779b3d802142289 (patch)
tree026d00d2cd80ac3728f3d7a6dcb7203a4c1afdad /dev-python/jsonpickle
parentdev-python/virtualenv: Bump to 20.4.3 (diff)
downloadgentoo-572bdd0aa7aad529ec9de1143779b3d802142289.tar.gz
gentoo-572bdd0aa7aad529ec9de1143779b3d802142289.tar.bz2
gentoo-572bdd0aa7aad529ec9de1143779b3d802142289.zip
dev-python/jsonpickle: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest2
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.5.0.ebuild52
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.5.2.ebuild49
3 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index 4d0ed801b7ce..e3699d6f0989 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1,3 +1 @@
-DIST jsonpickle-1.5.0.tar.gz 106088 BLAKE2B dcd35979a428180f10611638c831b083d9b8307729a0b19fe89b283c30ecac58477bd6a66e89c31e214dd2f100385d9933dc00d506e1f9bbb4b6ea9c3a0eaed3 SHA512 7828ded98173cb10908a9d60fa6b3f358add360d738cd85a90f012ca24b15c6bbb19c611027bdb0a4d25fe0649978ae59ff08fb7b717ef503a9916152aa6f849
-DIST jsonpickle-1.5.2.tar.gz 110239 BLAKE2B 3d4ee457a3f45dd1a6d1004d3fce66c95057958ec172227a7590631e479bd3a63dafe2ece04f5a0a78b9e283f61d949f5c359e4dd9270e162a3060e1032fc562 SHA512 609effeb5553c7c273aa621a8e86b4e630754eab1a948c505a08c98ff13e7f2622a0eb71374c03b69cf8e07c9a3b06fc9d282efba299a720b342424d642cfc6e
DIST jsonpickle-2.0.0.tar.gz 110336 BLAKE2B 574dab58418c5225a9364836d04eaabf3384e9dab404d191846a4bb41e9c8bbb51243a6a231ec8baf05ff9be337e12b5c96c46b74a327e9f05653ca81bf6ccf2 SHA512 acba11e5dfce116b27edfe0fdccdd74755e299aa43f873dd1ce547d947b58f14c1059c21d04007b5be0857f7ce69fe5355fb2edc47a99cc2217fe00297ca78d3
diff --git a/dev-python/jsonpickle/jsonpickle-1.5.0.ebuild b/dev-python/jsonpickle/jsonpickle-1.5.0.ebuild
deleted file mode 100644
index 6e5f3a477d2a..000000000000
--- a/dev-python/jsonpickle/jsonpickle-1.5.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# There are optional json backends serializer/deserializers in addition to those selected here
-# jsonlib, yajl.
-RDEPEND="
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_{6,7})
-"
-# toml via setuptools_scm[toml]
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx "docs/source"
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # too many dependencies
- rm tests/pandas_test.py || die
- sed -e '/pandas/ d' -i tests/runtests.py || die
- # broken with gmpy
- rm tests/ecdsa_test.py || die
-
- sed -i -e 's:--flake8 --black --cov --cov-append::' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv tests || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/jsonpickle/jsonpickle-1.5.2.ebuild b/dev-python/jsonpickle/jsonpickle-1.5.2.ebuild
deleted file mode 100644
index cfb3bc401537..000000000000
--- a/dev-python/jsonpickle/jsonpickle-1.5.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-# There are optional json backends serializer/deserializers in addition to those selected here
-# jsonlib, yajl.
-RDEPEND="
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_7)
-"
-# toml via setuptools_scm[toml]
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx "docs/source"
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # too many dependencies
- rm tests/pandas_test.py || die
- # broken with gmpy
- rm tests/ecdsa_test.py || die
-
- sed -i -e 's:--flake8 --black --cov::' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv tests || die "Tests failed with ${EPYTHON}"
-}