summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-07 09:59:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-07 11:33:41 +0200
commit54bac206c2b381c4c4a40f53e3be8cef86c6d3b7 (patch)
treed82fac8b9551d8053e2bbac63ff3892d11771f0d /dev-python/json5
parentdev-python/dns-lexicon: Bump to 3.11.0 (diff)
downloadgentoo-54bac206c2b381c4c4a40f53e3be8cef86c6d3b7.tar.gz
gentoo-54bac206c2b381c4c4a40f53e3be8cef86c6d3b7.tar.bz2
gentoo-54bac206c2b381c4c4a40f53e3be8cef86c6d3b7.zip
dev-python/json5: Bump to 0.9.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/json5')
-rw-r--r--dev-python/json5/Manifest1
-rw-r--r--dev-python/json5/json5-0.9.7.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index 5556fd234b47..eb363da6f955 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1 +1,2 @@
DIST json5-0.9.6.tar.gz 109927 BLAKE2B 91e01250a6a4bb3f2f8baa6a425b0721fac3888366c36de7aeed3f82123a48d91b06a1fb7458ef93f99a9bbf9f6b81e7d665a64f52652c495df99bb7af0d5cfd SHA512 6e1d8bc602ab7a13e4b495dc27df438b55f7474284af3a828f3fcae51f4b595e5a7d3be9693cdea4930721e2205db966392ba154d7b80ba7b9b6c9a7c0e7f7af
+DIST pyjson5-0.9.7.gh.tar.gz 110326 BLAKE2B 5d6da6654db8b902b211119d20be56dd3d8171100af3924c9dfe03f3bbae3581f0253e18985cf6ad8742d5b3454862ae39c56dee23bf7c1e849851755d71410e SHA512 625d1954105fdb358dafe4d1216201485ae47d3fb3c75c5a7b896899ecd5c59d92f675ff3d3349a7dc69d1dafa395b10d4a7c71f9dbd43d962965e03e5e799ac
diff --git a/dev-python/json5/json5-0.9.7.ebuild b/dev-python/json5/json5-0.9.7.ebuild
new file mode 100644
index 000000000000..f32c70f5016e
--- /dev/null
+++ b/dev-python/json5/json5-0.9.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest