summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 04:37:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 04:53:05 +0200
commit02be8a7bf65fdeccc0382e251f31f640092b7797 (patch)
treed3ac7ce6502a46d56d692b2bd2a8937fea838728 /dev-python/joblib
parentdev-python/tqdm: Bump to 4.66.0 (diff)
downloadgentoo-02be8a7bf65fdeccc0382e251f31f640092b7797.tar.gz
gentoo-02be8a7bf65fdeccc0382e251f31f640092b7797.tar.bz2
gentoo-02be8a7bf65fdeccc0382e251f31f640092b7797.zip
dev-python/joblib: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/joblib')
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-1.3.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index 09fb95a0d4a7..a3c496008e42 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1 +1,2 @@
DIST joblib-1.3.1.tar.gz 1986996 BLAKE2B fad0e61755b8d48595fcfcaeead7726242e8003acf0d50c4b0f810cb54c414fd25f6c3d420738b16d0667e06e05f5aaf8cd49e9abd693d620861acbb9eb0c16b SHA512 40aada55e64469887a323cad7049ad1fd7df815291c3e418544bce9b54af73bea67876de3469c3d0271aa4e2f6aa5f47c64c6be53730b1ba6b3e88814ddc0908
+DIST joblib-1.3.2.tar.gz 1987720 BLAKE2B f16235ead3ef0172a1e0dc2abad44967b029196f6c8c7a7e0c64283cac80e2b942ebfc2df5fa975bc152f574db023a9705f48b38855a11878e5c21e04cf7d831 SHA512 9b5acba1321351cf2ae548161ced18774b8b316aaf883cc8e77bf58898d1913361a3845d64f1f1f87e4e2394eafd92e0a6a8d67947db0c9a95a40e5f579baae6
diff --git a/dev-python/joblib/joblib-1.3.2.ebuild b/dev-python/joblib/joblib-1.3.2.ebuild
new file mode 100644
index 000000000000..72a905b5b040
--- /dev/null
+++ b/dev-python/joblib/joblib-1.3.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="
+ https://joblib.readthedocs.io/en/latest/
+ https://github.com/joblib/joblib/
+ https://pypi.org/project/joblib/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/loky[${PYTHON_USEDEP}]
+"
+# joblib is imported by setup.py so we need ${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # https://github.com/joblib/joblib/issues/1115
+ joblib/test/test_memory.py::test_parallel_call_cached_function_defined_in_jupyter
+ # unexpectedly pickleable?
+ joblib/test/test_hashing.py::test_hashing_pickling_error
+)
+
+python_prepare_all() {
+ # unbundle
+ rm -r joblib/externals || die
+ sed -e "/joblib.externals/d" -i pyproject.toml || die
+ find -name '*.py' -exec \
+ sed -e 's:\(joblib\)\?\.externals\.::' \
+ -e 's:from \.externals ::' \
+ -i {} + || die
+
+ distutils-r1_python_prepare_all
+}