summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-18 05:46:36 +0000
committerSam James <sam@gentoo.org>2021-11-18 05:46:36 +0000
commita4681c33b0ab7eb36b5580494e132853c91033f5 (patch)
treef1a900ed002340bcafc961c4db5eb4746773dd33 /dev-python/ipyparallel
parentdev-python/pydecomp: Stabilize 0.3-r2 arm64, #824310 (diff)
downloadgentoo-a4681c33b0ab7eb36b5580494e132853c91033f5.tar.gz
gentoo-a4681c33b0ab7eb36b5580494e132853c91033f5.tar.bz2
gentoo-a4681c33b0ab7eb36b5580494e132853c91033f5.zip
dev-python/ipyparallel: skip problematic slow tests
Trying to avoid getting into an ever-growing patch extending timeouts, especially given these additional tests are all based around timeouts/waiting in some form. We still get very good coverage without these, so it's not a problem. Closes: https://bugs.gentoo.org/823458 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/ipyparallel-7.1.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild b/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
index d683aba329d7..74b78974c2fc 100644
--- a/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
@@ -57,6 +57,15 @@ python_test() {
ipyparallel/tests/test_view.py::TestView::test_unicode_apply_result
ipyparallel/tests/test_view.py::TestView::test_unicode_execute
ipyparallel/tests/test_view.py::TestView::test_sync_imports_quiet
+ # Gets upset that a timeout _doesn't_ occur, presumably because
+ # we're cranking up too many test timeouts. Oh well.
+ # bug #823458#c3
+ ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
+ # We could patch the timeout for these too but they're going to be inherently
+ # fragile anyway based on what they do.
+ ipyparallel/tests/test_client.py::TestClient::test_activate
+ ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
+ ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
)
[[ ${EPYTHON} == python3.10 ]] && deselect+=(
# failing due to irrelevant warnings