summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-13 09:15:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-13 09:20:26 +0200
commit8970ec402a1596fb9969fc44f8fc908ba2edb533 (patch)
tree4b720983189f8fa165a041c1f16286c8effda705 /dev-python/idna
parentdev-python/uritemplate: Bump to 4.1.0 (diff)
downloadgentoo-8970ec402a1596fb9969fc44f8fc908ba2edb533.tar.gz
gentoo-8970ec402a1596fb9969fc44f8fc908ba2edb533.tar.bz2
gentoo-8970ec402a1596fb9969fc44f8fc908ba2edb533.zip
dev-python/idna: Bump to 3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/idna')
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-3.3.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index c85a3d584bf0..9c88fc85afaa 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1 +1,2 @@
DIST idna-3.2.tar.gz 243962 BLAKE2B c1c53533fd70a705822abf7debcb98d1cdc474df63eea22f0502585f9f2d143c4a35e575081951a8b98325e45ae5af46bba6632b04d40cb7181306e293377884 SHA512 2bc8e37abdc0570e5e13c9064f51630605806c3246a8d292511dad6f971610288212a2d881f9356ecb383f871e1477ccd60c4a5d6d7fd05254ff740d36543f35
+DIST idna-3.3.tar.gz 286689 BLAKE2B b804759b23157ff3d81fcd37f04baf83d7e522e98e8d842e3f228a242bbd9b1f9302ca28b8989a4221512bbbe92839cd593641830a0c6b2e12061b3501b1bd45 SHA512 70b7cc8718e7d7899c75cfe476f044eae5a2fa03801fc9c12e3a092627ca943ffc4a578f9b8a55e181a11564835e125cfaaa577c02a6461dbb97366e620e53ad
diff --git a/dev-python/idna/idna-3.3.ebuild b/dev-python/idna/idna-3.3.ebuild
new file mode 100644
index 000000000000..781010a1afb9
--- /dev/null
+++ b/dev-python/idna/idna-3.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna https://pypi.org/project/idna/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests setup.py