summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-19 08:08:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-19 10:42:48 +0100
commit89aa733cee9cf04196baa141ac2e0779963964e2 (patch)
treeb33e899e17a2cc3a58365026439e367379eca8d6 /dev-python/identify
parentdev-python/python-slugify: Bump to 7.0.0 (diff)
downloadgentoo-89aa733cee9cf04196baa141ac2e0779963964e2.tar.gz
gentoo-89aa733cee9cf04196baa141ac2e0779963964e2.tar.bz2
gentoo-89aa733cee9cf04196baa141ac2e0779963964e2.zip
dev-python/identify: Bump to 2.5.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.9.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index a5857e81e1dd..914e42324ab2 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,3 +1,4 @@
DIST identify-2.5.6.gh.tar.gz 101460 BLAKE2B c540934d4a482521758a64a1eb5e84b346eef0e0cccecbb9ad06e53e4b6872acb9c6fc94fccab9b75a7cf5658af78ad319d808a17f7ec44dfd08ae9c9a3b9f58 SHA512 9a35eb42767b0d2365b8da7c5aa5d7644272de5b65a505c5876cce0781222d8e52937b5c2d5594e560c5ab2fbbf4329555df15443b8f6110ac48880691af9089
DIST identify-2.5.7.gh.tar.gz 101472 BLAKE2B 519f35e08258dac5ff4b897f4ee55cf432641e57c55ff1d05d3fdf564aa7eed441ba839f222b430eae96f55a8e6a5d14a9c25fc78b3536dad59c3604a3bff7c2 SHA512 186a0c36e3abadd4b2db1439daa837fed55db706c4eb1821d9ecf1288cd667706b708e1251f84d67a480cdd28e6a57960443b707c327e19a9342f5e2afdb1a7c
DIST identify-2.5.8.gh.tar.gz 101476 BLAKE2B 2b59ac3cb416c7e3d6bd4031bfed30594b9be70f94d1e0d8e9f436b76e9241cde32f847c0f6b40607d2cb37ff7d67270a35a4d22be4cd6b216324e4eba30f136 SHA512 b43b8ba50d4d58a6d82c99141c708a45317f64693aea567105ed7f3957446e00102ddd303120a9f1238b04b6e0655e1dd6f807f6d878e972c7967a510f8b24b2
+DIST identify-2.5.9.gh.tar.gz 101496 BLAKE2B 045e32b6aa84cedee100332c9b26d1fbbc32f704ef1048ce380fcc40c8a3fcf2e5c96db83058b04d7ead6dea0681ea114e6469d89aa7cd10458ce98cb3f77c58 SHA512 fdecd728bed3828d3a5465943b390ce3aab05255ba06249f462a2367dcd3702ef85fbe57e06562a951e3eeb24f7f417b04d54e30bd711802a8afe37c2e1eb1f0
diff --git a/dev-python/identify/identify-2.5.9.ebuild b/dev-python/identify/identify-2.5.9.ebuild
new file mode 100644
index 000000000000..8ce2bd5b0e7d
--- /dev/null
+++ b/dev-python/identify/identify-2.5.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest