summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-02 15:08:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-02 15:08:33 +0300
commita84561def057f2c3c2c8d505d4c92502f2bd6f0f (patch)
tree32ba59df08112d7c2436c9ef27c8d2d64f796991 /dev-python/hypothesis
parentdev-python/hypothesis: Stabilize 6.46.11 ALLARCHES, #855827 (diff)
downloadgentoo-a84561def057f2c3c2c8d505d4c92502f2bd6f0f.tar.gz
gentoo-a84561def057f2c3c2c8d505d4c92502f2bd6f0f.tar.bz2
gentoo-a84561def057f2c3c2c8d505d4c92502f2bd6f0f.zip
dev-python/hypothesis: drop 6.46.9
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.46.9.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index a95fc5ed958f..4d8a6af6ac3e 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -7,4 +7,3 @@ DIST hypothesis-hypothesis-python-6.47.2.gh.tar.gz 9314053 BLAKE2B df607e7d81a28
DIST hypothesis-hypothesis-python-6.47.3.gh.tar.gz 9314739 BLAKE2B 282b012e020fc6494b628ba629c576f604db831c219878ab92539fbd1d980f3363e490ef35f888b68902661dd82e682393641d13a882c1177d8570ec232b217a SHA512 c7231ff06ae5846f718e76c48ed4bb8a1fc0f9aff80c7ddd1ff0ead219eb93dcc7f9d5c5e591390661e81a33bcac79773ea620cfe3f246210114635f0c089144
DIST hypothesis-hypothesis-python-6.47.4.gh.tar.gz 9314838 BLAKE2B 183048d7d784f8e64bcac1f5bb53b6b9f945b38d555aebd84d0966bcf64178e952f767dcf63122d9b3e8d41d79034b4b11074335e5dbb7575b5f78e152d05c25 SHA512 17a7388ac03ea9029bc5a90f24aa85c3f825bd04ceee963ff7f144ff675b0465afdd22edc5608931f1fd60e83c59d10be24dd74ed64015f942c3f09956b652d7
DIST hypothesis-hypothesis-python-6.47.5.gh.tar.gz 9315253 BLAKE2B f1b9829c2b0ba7f82dd49289feaf22100901674e0f394520c3c8d43d2eaab77669cc9d8f355455c1ea23210a17786c8ee6e982d7ca49067c51571491e3c7f43b SHA512 f08d1ac0237292fb3232e0ba11e81520a16f03d2c266f4d05495ffc3d1e801de7fbceee1973c73311f2b18e0cdc88988a2635968e1dd5c493f6887e5d63812fe
-DIST hypothesis-python-6.46.9.tar.gz 9311955 BLAKE2B f8cf7e216650401ea8a9b427311d10bc65a21b79eb231864c4ff429baea4600f8d84b05e4b94120551ebe17f1b4b99a65e76157efe9d0a133ad68c22b1c46452 SHA512 e4fed5210ba11977958d4d14f9fb32427b812ea7903f391bbf977ade7ae268770e846b0cd2193585f519a02681e4fabfead23eea5bcededaccc0e7a9857e98cf
diff --git a/dev-python/hypothesis/hypothesis-6.46.9.ebuild b/dev-python/hypothesis/hypothesis-6.46.9.ebuild
deleted file mode 100644
index 9435f6b2eaa4..000000000000
--- a/dev-python/hypothesis/hypothesis-6.46.9.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-CLI_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 multiprocessing optfeature
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="cli"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
- cli? (
- $(python_gen_cond_dep '
- dev-python/black[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- ' "${CLI_COMPAT[@]}")
- )
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # subtests are broken by warnings from random plugins
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
-
- epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
-}
-
-python_install() {
- distutils-r1_python_install
- if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
- rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
- fi
-}
-
-pkg_postinst() {
- optfeature "datetime support" dev-python/pytz
- optfeature "dateutil support" dev-python/python-dateutil
- optfeature "numpy support" dev-python/numpy
- optfeature "django support" dev-python/django dev-python/pytz
- optfeature "pandas support" dev-python/pandas
- optfeature "pytest support" dev-python/pytest
-}