summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-14 06:49:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-14 07:47:46 +0200
commit14307a18d4386fa2becc537e8951b3004eb3e02c (patch)
tree83c98b6b773f0b32e9fb045e22585b5e17c69268 /dev-python/hypothesis
parentwww-client/firefox: add 126.0 (diff)
downloadgentoo-14307a18d4386fa2becc537e8951b3004eb3e02c.tar.gz
gentoo-14307a18d4386fa2becc537e8951b3004eb3e02c.tar.bz2
gentoo-14307a18d4386fa2becc537e8951b3004eb3e02c.zip
dev-python/hypothesis: Bump to 6.102.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.102.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e877a65c2999..c63d41ec4c99 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -6,3 +6,4 @@ DIST hypothesis-6.100.6.gh.tar.gz 9456232 BLAKE2B 348f1ccbd4947ac6811eefd7ba997c
DIST hypothesis-6.100.7.gh.tar.gz 9456557 BLAKE2B b05da95267cb4920aac221a3f2d6ade7917d038358a6233e84fea58b0a6e478fc156ff771219fce80c99eb1c6eba5eb01b6c0bc5351ba26aafcedf3689afb414 SHA512 ba8453951cbfc52c1a6f3d17a1f723f73db105d4184daa1a4d9034f667f9de774b819e707fd04197ed69fc61380667df0c1915f7ed3d9a6d18a1543c261311b5
DIST hypothesis-6.100.8.gh.tar.gz 9458567 BLAKE2B 3deb2c90cbc283451633272954e5ca317d6615d80e37545a583fb2cbdd9e7761ecb158c13cde99daddaf4a0310ed9c616d85be488942a227c505aa2de796c2b0 SHA512 449d1f319405c2e9d65d34926c5d26c1ceebfb8ae61474ed487d459efc7c2640a6f119f1f3c367ef3098629d787a82e3d8ec50970b603358ded34e8dfb73474f
DIST hypothesis-6.101.0.gh.tar.gz 9458712 BLAKE2B b5a920e835fdf3bec6a1c8d21cc35833ec15192a512352a8630b5d7a7428d345b78061f5ee1571aff543ddc65586825de35933b3dc6de479880ddbd8509e352d SHA512 7e73074af127de0987d7b09fa71e0cfae47bbf195e621be3fd811474893bfba04d5b885e3bd7a46f707faeb2420abf93921c2c36c15c25672e400320974c7f7c
+DIST hypothesis-6.102.1.gh.tar.gz 9459939 BLAKE2B 36edbaf4ad89af3c4554e05ed395b29681b39708cd85a35cd5662766ce08ac95564a2b7ff7892e98df3fad1e729b779d00fcce86c2d17b879a21f3c877156875 SHA512 acb2b5f62e9f23eb379d61705f22330d9e81f7a23164bbdd196124fc3a67ba1265125597f840fa135f35af6f626229b3340b9557b2d69fc81f0b08c99d948e18
diff --git a/dev-python/hypothesis/hypothesis-6.102.1.ebuild b/dev-python/hypothesis/hypothesis-6.102.1.ebuild
new file mode 100644
index 000000000000..c2bf166b155f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.102.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 python3_13 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}