summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-05-19 15:28:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-05-19 15:40:29 +0200
commitbbff961f50094eff908eccb3b1d6e953c6d5f65f (patch)
tree0272723b3dde77bd635b472e0667296f04273539 /dev-python/hatch-jupyter-builder
parentdev-python/jupyter-lsp: add 2.1.0 (diff)
downloadgentoo-bbff961f50094eff908eccb3b1d6e953c6d5f65f.tar.gz
gentoo-bbff961f50094eff908eccb3b1d6e953c6d5f65f.tar.bz2
gentoo-bbff961f50094eff908eccb3b1d6e953c6d5f65f.zip
dev-python/hatch-jupyter-builder: new package, add 0.8.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/hatch-jupyter-builder')
-rw-r--r--dev-python/hatch-jupyter-builder/Manifest1
-rw-r--r--dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild38
-rw-r--r--dev-python/hatch-jupyter-builder/metadata.xml13
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/hatch-jupyter-builder/Manifest b/dev-python/hatch-jupyter-builder/Manifest
new file mode 100644
index 000000000000..7fd144669a59
--- /dev/null
+++ b/dev-python/hatch-jupyter-builder/Manifest
@@ -0,0 +1 @@
+DIST hatch_jupyter_builder-0.8.3.tar.gz 54754 BLAKE2B d64a90ba0e06dbbcfa3f2d27d88185f68bc6cadd885fd3691e01d129cb1d73d62efd2d230fe80dd2d8d1323b5efa4d3208f099663b2ed082a196a1b8fc39412e SHA512 c4dc0605338bafeeba21cc7260005815654d3e4646296d91af6fb3199be8645a06b2226608e6b0558ee01c7eed682162eefcf686a7e20636031b95c3a11ae265
diff --git a/dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild b/dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild
new file mode 100644
index 000000000000..2859ccbdd90e
--- /dev/null
+++ b/dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A hatch plugin to help build Jupyter packages"
+HOMEPAGE="
+ https://pypi.org/project/hatch-jupyter-builder/
+ https://github.com/jupyterlab/hatch-jupyter-builder
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/hatchling[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Calls pip, requires internet
+ tests/test_plugin.py::test_hatch_build
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/hatch-jupyter-builder/metadata.xml b/dev-python/hatch-jupyter-builder/metadata.xml
new file mode 100644
index 000000000000..af696c7da7fe
--- /dev/null
+++ b/dev-python/hatch-jupyter-builder/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">hatch-jupyter-builder</remote-id>
+ <remote-id type="github">jupyterlab/hatch-jupyter-builder</remote-id>
+ </upstream>
+</pkgmetadata>