summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/guppy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/guppy')
-rw-r--r--dev-python/guppy/Manifest1
-rw-r--r--dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch57
-rw-r--r--dev-python/guppy/guppy-0.1.10-r1.ebuild49
-rw-r--r--dev-python/guppy/metadata.xml13
4 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/guppy/Manifest b/dev-python/guppy/Manifest
new file mode 100644
index 000000000000..74dbfccd2b39
--- /dev/null
+++ b/dev-python/guppy/Manifest
@@ -0,0 +1 @@
+DIST guppy-0.1.10.tar.gz 484906 SHA256 00118c000e451063ea16bb6a3b52632d10960c44c0014553c287dce5c03813df SHA512 ea48fd19d7fe9a24832364599b8843304e95ccd1ccf3a9a475456ba25af2a4be94991dcb61deb854b740c2358d280579e756177236b3c73cb0de100bdf0286ce WHIRLPOOL 81b23d17f66d012865627d3f44edd89e63897d0a5e00b7e98d76d5abed3e4c296a1ab00b7dba32f02f0df7fb460c39c0672d6bc157cd74c478b39a87fb4d199c
diff --git a/dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch b/dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch
new file mode 100644
index 000000000000..fabbe4cda512
--- /dev/null
+++ b/dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch
@@ -0,0 +1,57 @@
+diff -ur guppy-0.1.9.orig/guppy/sets/test.py guppy-0.1.9/guppy/sets/test.py
+--- guppy/sets/test.py 2009-06-23 21:48:32.000000000 +0800
++++ guppy/sets/test.py 2012-11-07 16:59:38.383392670 +0800
+@@ -4,6 +4,11 @@
+ # so wouldn't check so much with python -O.
+
+ import gc, random, sys
++if sys.version_info[:2] == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
++
+ try:
+ import numpy.random
+ except ImportError:
+@@ -211,6 +211,7 @@
+
+ '.nython off'
+
++@unittest.skip("Class broken")
+ class Test:
+ faster = 1 # Set to 1 if test should be faster (less exhaustive) than normally
+
+diff -ur guppy-0.1.9.orig/guppy/heapy/test/test_View.py guppy-0.1.9/guppy/heapy/test/test_View.py
+--- guppy/heapy/test/test_View.py 2009-06-12 18:20:53.000000000 +0800
++++ guppy/heapy/test/test_View.py 2012-11-07 17:23:52.289280501 +0800
+@@ -1,4 +1,11 @@
+ from guppy.heapy.test import support
++import sys
++
++if sys.version_info[:2] == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
++
+ class TestCase(support.TestCase):
+ def setUp(self):
+ support.TestCase.setUp(self)
+@@ -55,6 +55,7 @@
+ p = iso(z).referents.indisize
+ self.aseq(p, iso(y).indisize)
+
++ @unittest.skip("broken test")
+ def test_horizon(self):
+ iso = self.iso
+ h = self.View.horizon()
+diff -ur guppy-0.1.9.orig/guppy/heapy/test/test_all.py guppy-0.1.9/guppy/heapy/test/test_all.py
+--- guppy/heapy/test/test_all.py 2009-06-18 21:44:11.000000000 +0800
++++ guppy/heapy/test/test_all.py 2012-11-07 17:34:04.036233306 +0800
+@@ -1,7 +1,6 @@
+ import sys
+
+ autotests = (
+- 'dependencies',
+ 'Classifiers',
+ 'heapyc',
+ 'ER',
diff --git a/dev-python/guppy/guppy-0.1.10-r1.ebuild b/dev-python/guppy/guppy-0.1.10-r1.ebuild
new file mode 100644
index 000000000000..90e52f887f39
--- /dev/null
+++ b/dev-python/guppy/guppy-0.1.10-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Guppy-PE -- A Python Programming Environment"
+HOMEPAGE="http://guppy-pe.sourceforge.net/ http://pypi.python.org/pypi/guppy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.9-rm_BrokenTests.patch )
+
+python_prepare_all() {
+ sed -e 's:_PyLong_AsScaledDouble:_PyLong_Frexp:' -i src/sets/bitset.c || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${PYTHON}" setup.py build install --home="${T}/test-${EPYTHON}" \
+ || die "Installation of tests failed"
+ pushd "${T}/test-${EPYTHON}/lib/python" > /dev/null
+ "${PYTHON}" guppy/heapy/test/test_all.py || die "tests failed"
+ popd > /dev/null
+}
+
+python_install_all() {
+ # leave the html docs for install as the setup.py dictates but rm if set by IUSE doc
+ if use doc; then
+ local HTML_DOCS=( guppy/doc/. )
+ find "${D}$(python_get_sitedir)" -name doc | xargs rm -rf
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/guppy/metadata.xml b/dev-python/guppy/metadata.xml
new file mode 100644
index 000000000000..65906dfb11c6
--- /dev/null
+++ b/dev-python/guppy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">Guppy-PE is a programming environment providing object and heap memory
+ sizing, profiling and analysis. It includes a prototypical
+ specification language that can be used to formally specify aspects of
+ Python programs and generate tests and documentation from a common
+ source.</longdescription>
+ <upstream>
+ <remote-id type="pypi">guppy</remote-id>
+ </upstream>
+</pkgmetadata>