summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-17 08:12:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-17 08:40:53 +0100
commit353c161c1f26b9ec6466384f51e32d4fb9f60286 (patch)
treec81d676ea2cf066f75804c56b9d25eea9f6100e4 /dev-python/griffe
parentdev-python/pytest-asyncio: Bump to 0.23.4_alpha2 (diff)
downloadgentoo-353c161c1f26b9ec6466384f51e32d4fb9f60286.tar.gz
gentoo-353c161c1f26b9ec6466384f51e32d4fb9f60286.tar.bz2
gentoo-353c161c1f26b9ec6466384f51e32d4fb9f60286.zip
dev-python/griffe: Bump to 0.39.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.39.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 23e54045832e..475fc049d167 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.38.1.gh.tar.gz 201135 BLAKE2B cdd1b7a24bb1afa6cdf68cffa696b8a19886d03b97ab6eb821fc9db150b1cd9d2e64de65f55c78f64663448e4b268c12b7d95c512e2dac3418489f0b0ef2f9c3 SHA512 74dd48d687edd399ac5da10454e68d9b226ad1b0418d9df583c364f65f5922cc29e109f1fafb3914a73a7217720f2305a4949324736a693f0065b8cae1f591d1
+DIST griffe-0.39.0.gh.tar.gz 214713 BLAKE2B e27015592ffc1a817c6236ae7a242f4968ba7ad2c649541bad9c6c31ba0459df4d7122382a6a776117bf80afb563f50a736d3d6851fcceed3113ac8372af0969 SHA512 b872c929f5dd32d7c63f3f199755c8b1e4b9bae05b21b3c4a477f3ba94ca24170907faf0d4e878b43403f448f6d067300d80e612633d801f993f5e13187f572f
diff --git a/dev-python/griffe/griffe-0.39.0.ebuild b/dev-python/griffe/griffe-0.39.0.ebuild
new file mode 100644
index 000000000000..73f99c53e1af
--- /dev/null
+++ b/dev-python/griffe/griffe-0.39.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)