summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-12 22:18:16 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-12 22:18:59 +0200
commitb388550a7544cc286128edb43d27d595cafd6cc6 (patch)
tree8931ab5b61faf8a95be16aec73014bc2fc15f283 /dev-python/google-auth
parentdev-python/sqlalchemy: add 1.4.44 (diff)
downloadgentoo-b388550a7544cc286128edb43d27d595cafd6cc6.tar.gz
gentoo-b388550a7544cc286128edb43d27d595cafd6cc6.tar.bz2
gentoo-b388550a7544cc286128edb43d27d595cafd6cc6.zip
dev-python/google-auth: add 2.14.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.14.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 10b9832e8f1e..cef87724a6af 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-2.12.0.tar.gz 209325 BLAKE2B a6f754262dd7b75796dd63f4b7a2161ba959a3103c51cacb3d5f4ba3d17efdd36e1836ce360fa108b5dbce710743bfacf3b8b054de0e235590ba15eae8f3cdf3 SHA512 59209299631b7ea7d11e6787c33a304bbed5bca2173148d8c69595fc573f8915f6e3b601ed96686568f517cbbea71e18be228874334733629fbdd030976821cb
DIST google-auth-2.13.0.tar.gz 216209 BLAKE2B 4e88062d89ca9976e0d87a93012c8ca318f9068452fde365970aab1d6ab4985aad378a038e36e0a82aca4665a196c412287a84b58c831edc9483d02fa4ed2489 SHA512 253dd17466850b20212c8cbbeb29c35dbffb2f3205867c7fdf74e400e4f2f9bf3c9ca6ffc814e5c3e9c7cc918a6cc60e696bc98c5d969761101dee4109b7018e
DIST google-auth-2.14.0.tar.gz 219265 BLAKE2B 93ba6f54e28cc8846aecc9226de07ec66762b8f757b40b5796050209a02ff758475fddd2bf82d4374804058c99b80590e5f4a390642a3ad6ca2e9348d1a6b3a1 SHA512 ae85da8335bd00dcce9e7854fa92a114f81c61687a20274058d482dc3d6bb2396d5de6c2865ad64f5c892ed9a9abf8b9f39456c1fd1760a67298ecfaf40c8163
+DIST google-auth-2.14.1.tar.gz 220079 BLAKE2B 7e0958bd0f83bb9e47e5ea191a6f90f221630c67638082fdafb2b925e44eb9c68f6b91e86ab8b7869edb70de21c3be44041ded6507c2819754b19b13bd342a0c SHA512 1aec6b7104d71f58d1bc76472b204261eb6fc3030d0ed5f523bb125a9169544bc6266a8ae4573fce28423b689f2efcf57aadafc6c21876824fc17b2a96bbed95
diff --git a/dev-python/google-auth/google-auth-2.14.1.ebuild b/dev-python/google-auth/google-auth-2.14.1.ebuild
new file mode 100644
index 000000000000..de5188c8fdb8
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.14.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}