summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-24 09:47:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-24 09:52:01 +0100
commitd541a9f178aabf48466f616cc2da10377e7c4047 (patch)
tree76cf3d531784f4fe0f3102bb30df643592920816 /dev-python/google-api-python-client
parentdev-python/oauth2client: Bump to EAPI 8 / PEP517 (diff)
downloadgentoo-d541a9f178aabf48466f616cc2da10377e7c4047.tar.gz
gentoo-d541a9f178aabf48466f616cc2da10377e7c4047.tar.bz2
gentoo-d541a9f178aabf48466f616cc2da10377e7c4047.zip
dev-python/google-api-python-client: Tested on py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.38.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.38.0-r1.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.38.0-r1.ebuild
new file mode 100644
index 000000000000..e48dbf2e8a66
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.38.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}