summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-19 22:48:43 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-19 22:50:44 +0200
commit3cdcee1d485e27d8585fe4076b175985daaef68f (patch)
treeb967d3935ff510cdb8735fbc70a8dcb0e7759c3a /dev-python/fonttools
parentdev-python/deepmerge: add 1.0.0 (diff)
downloadgentoo-3cdcee1d485e27d8585fe4076b175985daaef68f.tar.gz
gentoo-3cdcee1d485e27d8585fe4076b175985daaef68f.tar.bz2
gentoo-3cdcee1d485e27d8585fe4076b175985daaef68f.zip
dev-python/fonttools: add 4.28.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.28.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 1a70a6f6fdc3..edd7b8285a47 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -2,3 +2,4 @@ DIST fonttools-4.28.1.tar.gz 2654329 BLAKE2B 4d1f2f5caea6ee3ae73a7791ad34da0c493
DIST fonttools-4.28.2.tar.gz 2940111 BLAKE2B 32f67f2c270520d9e2091052242e504b9a8e459a87f233e22f50bfe3d17309a09a3c7ad5da20a3411df1c7c58b790dd395535407fdeddb02e7391c28d8d08fa3 SHA512 0295c571e92e71f6467b06bd89afacae76861e374147a2051fe3f5323176c3f3458b977ba2ed25cadcdba9e55b325b6febc50bc9c539d8806471730a15faed47
DIST fonttools-4.28.3.tar.gz 2944993 BLAKE2B bac7408759ae2854023d5e6f840eb34d431daf0e14ec9fd8d4ac2ecc4ea8e473456611c3531b9131035164f69ba2363a3835206d068b71d4a2ae6ec179d2a32d SHA512 b90d05cedbd06f476c210f2961ebd11c64043785ef43fda2b81fd22126b12642ab63e51363bc22524bb18ee781fa9a8a71edb187b6c69fbf838e0c20f3c9ba0b
DIST fonttools-4.28.4.tar.gz 2945369 BLAKE2B f178552aca7b41dcec1c03d2a7c3de17cdb5f4b2e057a75e196e78a098b9959a038a9a3b14ee8546d5ea12e3546c22d2a8d9b34a922c0822bf52f78bc03f4f54 SHA512 9ecdf4186e24a8a44c6010432d71f1689ebf8461a404dde71259eb4712c4987d94bbe31b33ad6943fb2e0105fc9f8e9032a94e6ccbb4ac01fe330bb700a39c63
+DIST fonttools-4.28.5.tar.gz 2948092 BLAKE2B b35f4be68cfc2be6afb209c2caee38f7088a1a17dea85fac0f40183b61a3eded59fab47f703587097669f8823a8dbc2e84b0df58305597784bed7f8c2e2b0f28 SHA512 5d87f4fadbcb447d1c1a1e97550f6a477d74bfe8647d14b35097e03e6a45a1a01632d2092483d675c523f97d4a04f39aa9b3175e535b1e1a4f19d619eb40ad5f
diff --git a/dev-python/fonttools/fonttools-4.28.5.ebuild b/dev-python/fonttools/fonttools-4.28.5.ebuild
new file mode 100644
index 000000000000..b98e2fa9734d
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.28.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ DISTUTILS_ARGS=( --with-cython )
+}
+
+python_test() {
+ distutils_install_for_testing
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}