summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-28 08:25:04 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-28 08:25:04 +0100
commit8d778748c6cd34ef85c1bd2c4842e7ea21d0fc4d (patch)
treea35ab18e4335927ce13fc05ec705789b12b9cd8b /dev-python/flexmock
parentdev-python/pbs-installer: Bump to 2024.12.19 (diff)
downloadgentoo-8d778748c6cd34ef85c1bd2c4842e7ea21d0fc4d.tar.gz
gentoo-8d778748c6cd34ef85c1bd2c4842e7ea21d0fc4d.tar.bz2
gentoo-8d778748c6cd34ef85c1bd2c4842e7ea21d0fc4d.zip
dev-python/flexmock: Bump to 0.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flexmock')
-rw-r--r--dev-python/flexmock/Manifest1
-rw-r--r--dev-python/flexmock/flexmock-0.12.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/flexmock/Manifest b/dev-python/flexmock/Manifest
index 9da2f3ecbc27..0b504e00620c 100644
--- a/dev-python/flexmock/Manifest
+++ b/dev-python/flexmock/Manifest
@@ -1 +1,2 @@
DIST flexmock-0.12.1.tar.gz 52765 BLAKE2B 5b1317ff0d9b1a14d58b47d558a88f38ff7aef40fd349d0e70e9d9688a89b0464419aca953ba481afe3f4ccf88217b76c34e8bf1a053c62caaa1f9877ad35183 SHA512 898876695e9eff4fc37a9d3f6b93a34869500a3ce740e7c43cd4c4317ba59f2ea16ec11b4094037e6b56755047584870fa3af27a041003eb6200d79b3a716e63
+DIST flexmock-0.12.2.tar.gz 53195 BLAKE2B f1f0b33f3f75ba87e4fb983df2461b0478f02402de31edeeede017a08c61ea0b3a1f69408b0360dcbccc1130bbf93161e5f0767f888e83dfa757e0744ab44089 SHA512 8fac117032c6321b05dfb6c4d53e2f3e29c121ef9029d70aeaae8a96aadbb4e0120f319817c0a5e7699cd80d765f974d128a8e3d7b151e30c1a8ff834b87dbd5
diff --git a/dev-python/flexmock/flexmock-0.12.2.ebuild b/dev-python/flexmock/flexmock-0.12.2.ebuild
new file mode 100644
index 000000000000..8d764b843b59
--- /dev/null
+++ b/dev-python/flexmock/flexmock-0.12.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Testing library to create mocks, stubs and fakes"
+HOMEPAGE="
+ https://flexmock.readthedocs.io/
+ https://github.com/flexmock/flexmock/
+ https://pypi.org/project/flexmock/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_teamcity.py
+ tests/test_testtools.py
+ tests/test_unittest.py
+ )
+ epytest -p no:flaky
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}