summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-21 09:19:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-21 09:19:07 +0300
commit1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187 (patch)
treedd50913a06a887e77db841c314d58732c976105a /dev-python/flask-api/flask-api-3.0.ebuild
parentmedia-libs/ladspa-sdk: bump to 1.17, cleanup and update (diff)
downloadgentoo-1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187.tar.gz
gentoo-1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187.tar.bz2
gentoo-1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187.zip
dev-python/flask-api: add 3.0, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-api/flask-api-3.0.ebuild')
-rw-r--r--dev-python/flask-api/flask-api-3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/flask-api/flask-api-3.0.ebuild b/dev-python/flask-api/flask-api-3.0.ebuild
new file mode 100644
index 000000000000..0d56985e7d61
--- /dev/null
+++ b/dev-python/flask-api/flask-api-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browsable web APIs for Flask"
+HOMEPAGE="https://www.flaskapi.org/"
+# pypi mirror don't have docs folder
+SRC_URI="https://github.com/flask-api/flask-api/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( docs/about/release-notes.md docs/api-guide/* docs/index.md )
+ distutils-r1_python_install_all
+}