summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 10:08:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 10:16:08 +0100
commitb100fd7192ef3fa573578f3bdf134839e4ebbf81 (patch)
tree8e3843bab56116b538d0e300e8f5c39ca027a03c /dev-python/flask-api/flask-api-1.0.ebuild
parentdev-python/flask: Remove redundant versions (diff)
downloadgentoo-b100fd7192ef3fa573578f3bdf134839e4ebbf81.tar.gz
gentoo-b100fd7192ef3fa573578f3bdf134839e4ebbf81.tar.bz2
gentoo-b100fd7192ef3fa573578f3bdf134839e4ebbf81.zip
dev-python/flask-api: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-api/flask-api-1.0.ebuild')
-rw-r--r--dev-python/flask-api/flask-api-1.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/flask-api/flask-api-1.0.ebuild b/dev-python/flask-api/flask-api-1.0.ebuild
deleted file mode 100644
index d973e9e5ecad..000000000000
--- a/dev-python/flask-api/flask-api-1.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Browsable web APIs for Flask"
-HOMEPAGE="https://github.com/flask-api/flask-api"
-# pypi mirror don't have docs folder
-SRC_URI="https://github.com/flask-api/flask-api/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc docs/about/* docs/api-guide/* docs/index.md
-}
-
-python_test() {
- pytest || die
-}