summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-02-20 21:02:03 -0500
committerAaron Bauman <bman@gentoo.org>2019-02-26 23:36:57 -0500
commitd783d049e18cdb88ac8a8599036d1bbe551b98b3 (patch)
tree9e2a5de32676263e3659ad2bc5c6ecd1026848de /dev-python/flaky/flaky-3.5.3.ebuild
parentdev-tex/curve: EAPI7 revbump (diff)
downloadgentoo-d783d049e18cdb88ac8a8599036d1bbe551b98b3.tar.gz
gentoo-d783d049e18cdb88ac8a8599036d1bbe551b98b3.tar.bz2
gentoo-d783d049e18cdb88ac8a8599036d1bbe551b98b3.zip
dev-python/flaky: 3.5.3 version bump, EAPI=7
Closes: https://bugs.gentoo.org/678456 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11122 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/flaky/flaky-3.5.3.ebuild')
-rw-r--r--dev-python/flaky/flaky-3.5.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/flaky/flaky-3.5.3.ebuild b/dev-python/flaky/flaky-3.5.3.ebuild
new file mode 100644
index 000000000000..92528305918e
--- /dev/null
+++ b/dev-python/flaky/flaky-3.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+python_prepare_all() {
+ cat >> test/__init__.py <<- EOF
+ # coding: utf-8
+
+ from __future__ import unicode_literals
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}