summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-14 22:13:42 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 22:37:47 +0100
commitb2de982cd6d55bea175a50480a46c36a582de6cb (patch)
tree4fd68e9cbac9472d6365110658aefa824928bd46 /dev-python/fakeredis
parentdev-python/lz4: Bump to 4.0.0 (diff)
downloadgentoo-b2de982cd6d55bea175a50480a46c36a582de6cb.tar.gz
gentoo-b2de982cd6d55bea175a50480a46c36a582de6cb.tar.bz2
gentoo-b2de982cd6d55bea175a50480a46c36a582de6cb.zip
dev-python/fakeredis: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-1.7.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index a13e46a82b34..814702242121 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1 +1,2 @@
DIST fakeredis-1.7.0.gh.tar.gz 71108 BLAKE2B 64b4c8aa2891ac6afd7789e5a8dce4d1a0ccd6a5083b410fd051d871d4ea9748e9d687eb27bbaeea646747f4bf170089d3ef711d6db0d6a88d8b7e755d165b6d SHA512 a8c67929e63196fea45b85097aaf6bf7402679510e471a8d13bdc0f7320e983107416d3e515fa85b1d6a6217fb82dbda7b4425c3c80ac54a1ac50eee875b0fbd
+DIST fakeredis-1.7.1.gh.tar.gz 71151 BLAKE2B 87877c94a4c03ad6ff4b55f307526f712daa860257374a97a8f7bd29440d171467e18e4041ca56bb6af30df30481a3d5b13c7d0657ba3eb7673a653664ffbe8a SHA512 f41d9393ae50bae9de064678948f4364fc47db06f489782e5b428f449828ad5813b08b2fb053bef878b2a1b500edbb0ea1881449dbd12c2b6e385f6a2fba4c59
diff --git a/dev-python/fakeredis/fakeredis-1.7.1.ebuild b/dev-python/fakeredis/fakeredis-1.7.1.ebuild
new file mode 100644
index 000000000000..fc314cb64274
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-1.7.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/jamesls/fakeredis/
+ https://pypi.org/project/fakeredis/"
+SRC_URI="
+ https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/redis-py-4.2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/aioredis[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ test/test_aioredis2.py::test_blocking_unblock
+ test/test_aioredis2.py::test_pubsub
+ "test/test_aioredis2.py::test_repr[fake]"
+ test/test_hypothesis.py::TestJoint::test
+ test/test_hypothesis.py::TestFuzz::test
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ "test/test_aioredis2.py::test_failed_script_error[fake]"
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
+
+pkg_postinst() {
+ optfeature "Mock aioredis" dev-python/aioredis
+}