summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-14 20:33:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-14 20:39:16 +0200
commiteba456422c0ea94b5e17771681d9091f96b59065 (patch)
treedd87c9f8cfacef6dd69e4c5f784b6bcd1dc27684 /dev-python/ensurepip-pip
parentdev-python/setuptools: Bump to 65.0.0 (diff)
downloadgentoo-eba456422c0ea94b5e17771681d9091f96b59065.tar.gz
gentoo-eba456422c0ea94b5e17771681d9091f96b59065.tar.bz2
gentoo-eba456422c0ea94b5e17771681d9091f96b59065.zip
dev-python/ensurepip-pip: New split package, v22.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-pip')
-rw-r--r--dev-python/ensurepip-pip/Manifest1
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild27
-rw-r--r--dev-python/ensurepip-pip/metadata.xml11
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ensurepip-pip/Manifest b/dev-python/ensurepip-pip/Manifest
new file mode 100644
index 000000000000..7053d7b828df
--- /dev/null
+++ b/dev-python/ensurepip-pip/Manifest
@@ -0,0 +1 @@
+DIST pip-22.2.2-py3-none-any.whl 2044706 BLAKE2B 254427e593e44d9f1ce48276fd40f214e8ca9d27b6c31b7a6ed5fa4566df6b1f723215c6a1766a534ce18174f2363c383dbff19368d1b89f1519a53bebd34215 SHA512 142d3144c14b692c645613d98bf35dd91193128d5e21b61a8a702548f1247fac662499d6e39b65c0aa9a0444d2d92983fd8c410439796626485a4e1be99a102f
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild
new file mode 100644
index 000000000000..27ee812d0240
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}
diff --git a/dev-python/ensurepip-pip/metadata.xml b/dev-python/ensurepip-pip/metadata.xml
new file mode 100644
index 000000000000..4bc0932869e1
--- /dev/null
+++ b/dev-python/ensurepip-pip/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pip</remote-id>
+ </upstream>
+</pkgmetadata>