summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2017-06-05 08:58:22 +0200
committerSlawomir Lis <slis@gentoo.org>2017-06-06 08:23:45 +0200
commitdf8a3964a6d724905a1c548e35efb5ce7b5cf6b7 (patch)
tree160a26e104d411309aba04a3887b95a83c375460 /dev-python/django-durationfield
parentdev-python/django-sekizai: drop old (diff)
downloadgentoo-df8a3964a6d724905a1c548e35efb5ce7b5cf6b7.tar.gz
gentoo-df8a3964a6d724905a1c548e35efb5ce7b5cf6b7.tar.bz2
gentoo-df8a3964a6d724905a1c548e35efb5ce7b5cf6b7.zip
dev-python/django-durationfield: version bump to 0.5.4
Also updated to use PYTHON_USEDEP Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/django-durationfield')
-rw-r--r--dev-python/django-durationfield/Manifest1
-rw-r--r--dev-python/django-durationfield/django-durationfield-0.5.2.ebuild8
-rw-r--r--dev-python/django-durationfield/django-durationfield-0.5.4.ebuild26
3 files changed, 31 insertions, 4 deletions
diff --git a/dev-python/django-durationfield/Manifest b/dev-python/django-durationfield/Manifest
index ceaefdd8727f..133f118c1ef5 100644
--- a/dev-python/django-durationfield/Manifest
+++ b/dev-python/django-durationfield/Manifest
@@ -1 +1,2 @@
DIST django-durationfield-0.5.2.tar.gz 4324 SHA256 7fb097b4418c67284c99790e6927191e0fb5c014356d3e3d2b26e8919e37cdcf SHA512 de0ea6b9b86cf29d4a5813a80cf7a02f66d0774b58266799e83f8e734a1cf071352ae57d8f8ded8fb16f9a74dd284a4c146d98f75a78bf0463bf767e4156b3ad WHIRLPOOL 6607fb2a1169c963dcb798ce1d27cdf599f2c71bb6b6e8d55c549d502066c500c65b9bf497d8059158f4fef455705523b7270419d2cdbaa2de823c372af8492d
+DIST django-durationfield-0.5.4.tar.gz 4728 SHA256 29e3df5e28d2422b3ac5e5fd3129dc3285dba729df176c464e6ee73a0710a45a SHA512 84885ab7bb07ed3c5a64094a2beb7d4adcf8b0f9f2933ad2c1d4654789bd71aa7d2efd5c84931f22f81a51e8aaeb3ed9415a12c69dfd7354c2317ea912fdc610 WHIRLPOOL 7efb893bb62ed44e28022d691ed17cde1f779335d8923df851c1cc299df3cbce66d494911422ec306cca1890780b376c380118f8b859d38a1dedb49f266dfd9f
diff --git a/dev-python/django-durationfield/django-durationfield-0.5.2.ebuild b/dev-python/django-durationfield/django-durationfield-0.5.2.ebuild
index fa2675d3762c..23c9e23b4cf2 100644
--- a/dev-python/django-durationfield/django-durationfield-0.5.2.ebuild
+++ b/dev-python/django-durationfield/django-durationfield-0.5.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_{6,7},3_{3,4}} )
inherit distutils-r1
@@ -17,10 +17,10 @@ SLOT="0"
IUSE=""
RDEPEND="
- >=dev-python/django-1.4
+ >=dev-python/django-1.4[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
- dev-python/setuptools
+ dev-python/setuptools[${PYTHON_USEDEP}]
"
diff --git a/dev-python/django-durationfield/django-durationfield-0.5.4.ebuild b/dev-python/django-durationfield/django-durationfield-0.5.4.ebuild
new file mode 100644
index 000000000000..5a796ae34645
--- /dev/null
+++ b/dev-python/django-durationfield/django-durationfield-0.5.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_{6,7},3_{3,4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reusable app for adding a DurationField to Django"
+HOMEPAGE="https://pypi.python.org/pypi/django-durationfield"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.4[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"